Question Dell Optiplex 755's PCIe x16 slot stuck at x1 speed. Why?!

Jun 17, 2019
38
1
35
0
First of all, here are my specs:

Core 2 Duo E8400 3.0Ghz (6MB).
Inoo3D Nvidia GT440 "Mac Edition" 1GB (GDDR3), 96 Cores.
Kingston 4GB DDR2 800Mhz Dual-Channel.
Windows 7 Ultimate SP1 (64-Bit).

Now, the problem:

The other day, I tried to run Call of Duty: World At War on this machine. As you can see; this machine is more than capable of running this game at ~60FPS 720p and yet... I got like 20FPS maximum. The FPS was all over the place and it was simply unplayable.

'Dumbfounded', I opened GPUz and looked carefully at the specs. It occurred to me that my GPU is stuck at x1 PCIe v1.1! I tried to stress the slot by clicking the "?" button in GPUz, but nothing. Then I ran FurMark, same issue. Then I chose "Optimal Performance" in Nvidia Control Panel and Windows 7's control panel, nothing.

Then I updated my BIOS from A07 to A22, same. Then I revered the BIOS from A22 to A11 (I don't know why, so please don't ask me!), still nothing.

Here's the GPUz screenshot:


Now, I'm out of ideas and was wonder if you've got any ideas?

Thanks!
 

ASK THE COMMUNITY

TRENDING THREADS