dell optiplex GX620 doesn't start up

Ilyass TheCoder

Reputable
Aug 15, 2014
45
0
4,530
0
Hello guys ,

My Dell optiplex GX620 doesn't start up ,

here is the problem :
after pressing the start/power button , all I can here is the high fan noise , nn Beeps at all , nothing displayed on the monitor , Orange LED ,

Here what I did :
I removed all the ram's and start the pc again , noo beeps .
removed the bios battery too but the same problem .
tried an other PSU but the same problem
cleaned the pc , new RAM's but nothing .

I hope you can help me with this problem , and I'am here for any additional information you need it and welcome to any suggestion from you guys .

Thank you in advance

PS : my brother has the same problem on his Dell ( cor 2 duo )
 

ex_bubblehead

Glorious
Moderator
It's been reported that the front USB ports can cause this. Usually happens when someone jams something into one of the ports and shorts it out. Disconnect the front USB ports from the motherboard and see if this clears the fault. If not you may be looking at a failure on the motherboard. The GX620 is ancient and not worth repairing if the motherboard is toast.
 

Ilyass TheCoder

Reputable
Aug 15, 2014
45
0
4,530
0


I just removed the front usb cable from the motherborad and the pc doesn't start at all . and after removing bios battery ... , the Fan noise start again like before removing the front usb cable
 

Ilyass TheCoder

Reputable
Aug 15, 2014
45
0
4,530
0


Sorry bro , all I want is to fix my pc :(

I will check this thread later to see if someone add any suggestion or a solution .

thank you for your help
 

Similar threads


ASK THE COMMUNITY