• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question Dell optiplex990 power button failure?

Mike2009

Distinguished
Mar 16, 2009
65
0
18,640
4
System specs :
Dell optiplex990 MiniTower and motherboard
currently a Core I5 2400
2 500gb wd blue drives( adding a SSD once this issue is for sure resolved)
ASus GTX 1060 6gb card
Seasonic S12III 550watt power supply ( just installed today trying to fix the issue)

last week my pc began randomly shutting down ( like someone pressed the power button quickly and the windows closed programs and shutdown fully )

this got progressively worse rather quickly within the past few days the system went from doing that to a hard power down, but all the basic signs of life were still there telling me the power supply was still working, , it got to the point where pressing the power button was doing nothing half the time and would only stay on for a few minutes the turn back off. well i swapped the powersupply today and it still did it . so i unplugged the power switch from the motherboard and flipping the power supply on it turned on and has stayed on , my only thought is what could've caused the switch to go bad like that? if that is indeed the issue ... Ill know when the new power switch gets here in a day or so.
 
IF the system will stay on long enough to check temps, that would be worth looking at as well...

Certainly, a failing PSU can cause 'instant power off' syndrome as well..

If you power switch wires do not lead to a custom harness, you can follow the two ends that connect to the mainboard (labeled PWR SW) and disconnect them, or use the RESET SW wires connected to those two pins instead... (If the RESET SW wires are connected to the PWR SW connection points, the actual reset switch effectively becomes your power switch. If symptoms remain, your power switch is not the issue...
 

Mike2009

Distinguished
Mar 16, 2009
65
0
18,640
4
on this motherboard the power switch connection is on the upper edge of the board compared to the rest of the IO , theres 5 wires running to a single blue led power switch to front of the case,,, unplugging that connector seems to switch the system to power on when power supply is turned on etc so the reset switch is basically the power switch as well , it works as follow press quickly to power on ,, hold in a few seconds to power off , technically there is no reset really. and this is a brand new power supply I just got to try and fix this issue so definitely not a power supply issue, seems to be the switch is the root cause ,, but Ill know more in the next few days , since I have replacement power switch being shipped to me . just odd it happened so randomly and quickly.
 

ASK THE COMMUNITY

TRENDING THREADS