Question Dell T7500 2-3-4 Flashing, Power Amber

Samrezkhan

Reputable
Dec 21, 2016
12
1
4,515
0
Hi Guys,

I Have a Dell T7500 and it is showing 2-3-4 Flashing lights with Power at Amber.
I have been facing this problem since last year, and there is not any specific solution to this.
My Processor is x5690, Bios is updated, PSU is fine, GPU is fine.

I have changed the processor an x5650 to make it work, and it works, then the problem comes back again.

The Funny thing is, if i keep poking it on and off, maybe leave it for a few days, it turns back on as if nothing had happened. Works completely fine

But at times when turned on, it just FREEZES during work. I manually restart it, and it turns on,everything works fine. But freezes again.
Now it has stopped turning on and I am just tired TBH.

This is my work PC, if anyone has a definite solution let me know.

I have reset bios, installed most updated. I have changed processors, changed heat sinks, places CPU correctly(as some say it has issues when CPU isnt placed correctly)
I have tried everything in the book but nothing is a sure check out of it.

UPDATE:
I replaced heatsink, it turned on.
But kept giving Hardware error and kept restarting. Automatically it moved forward.

Now it has booted to windows, but I am sure it will freeze again.
 
Last edited:

Samrezkhan

Reputable
Dec 21, 2016
12
1
4,515
0
I just replaced the Heatsink, and its booting now again.
But now moving to recovery, keeps restarting and hangs at times

Well, if there was a PSU issue it wouldnt be able to boot right?
HDD and GPU work fine.
No power issues there
 

ASK THE COMMUNITY

TRENDING THREADS