Question Dell USB ports stopped working

Jul 22, 2022
6
0
10
0
Hello, I own a Dell Inspiron 3576 with i5 8250U without dedicated graphics card and recently the problem started. I had dual boot Ubuntu and windows. My USB ports stopped working. After reboot they still didn't work, so I turned on the Dell diagnosis software in bios and everything worked to the next reboot. The troubleshooting worked 3 times, after that I wasn't able to get ports working. I tried update bios through windows, but installation media wont start. After a few reboots the ports started working and I was able to update the bios. I thought windows was a problem so I removed linux and kept only windows. From then on I was able to get ports working only once. Camera, Bluetooth, CD-ROMS, headphones jack stopped working with the ports. In device manager -> Universal Serial Bus controllers I see only Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft) and in properties device status is "This device cannot start. Code 10". Usually there are 5 driver's.

1. I tried update bios

2. I update drivers in windows

3. I used a dell support assistant

4. I installed the newest version of everything 5. I was looking for hardware issues (burns up resistors, MCU, capacitors) Has anybody had a similar problem and fixed it? The laptop is 5 years old but worked fine. Thanks for any advice.
 
Jul 22, 2022
6
0
10
0
check if the pins of the USB ports are fine or bent in some way
unplug all USB devices, eventually one is defective
I think the problem is in some communication MC, because nothing is connected to the PC and windows won't detect any USB port, camera, Bluetooth module, but sometimes with some miracle windows install drivers and everything works fine. I tried download drivers from dell site and install them, but they can't find devices.
 
Jul 22, 2022
6
0
10
0
Sounds like a faulty chip
Try ubuntu live, of it works there, reinstall windows

Do you use anti virus Software?
Maybe IT is prohibiting the USB Devices to connect properly sometimes
I can't boot from USB and I had Ubuntu, but it couldn't recognize hardware. I think the problem is in some USB, camera, bluetooth MC which is connected to cpu or some interface like i2c is defective at CPU. There are some MC at motherboard but i didn't identify them all, so i cant figure it out which mc drive that hardware.
 

helpstar

Polypheme
did you try installing the drivers manually and not by a Dell tool?
BIOS version installed is 1.16.0 ?

resolder all USB port connections

check the connections from the wi-fi /bluetooth module and the camera on the motherboard
 
Jul 22, 2022
6
0
10
0
did you try installing the drivers manually and not by a Dell tool?
BIOS version installed is 1.16.0 ?

resolder all USB port connections

check the connections from the wi-fi /bluetooth module and the camera on the motherboard
Yes, It has 1.16.0 version of bios. I cant identify any weird traces, most of them are inside board, but there is MEC1416-NU chip which control keyboard and embedded system of laptop. The usb's are probably connected to that chip. The bluetooth and wifi are at the same module and wifi is working. So I will check the chip, if it has some errors pins or traces through which it communicate with CPU.
 

ASK THE COMMUNITY