Question DELL XPS 9570 Freezing/Stuttering Issues

Hyziu

Honorable
Mar 22, 2015
10
0
10,510
0
Hello,

I purchased a used DELL XPS 9570 and it keeps freezing when in normal use for example web browsing or even whilst on desktop with no applications open. I use this laptop to play Valorant and some other games. Whilst I have a game open I have no freezing/stuttering issues but if I'm not playing games the laptop is freezing/stuttering.

I think it's an issue caused by the switch between the integrated graphics and the graphics card however I'm not sure how to fix it - all my drivers are up to date and all windows updates done.

My specifications:
I7 8750H
16GM RAM
512GB SSD
GTX 1050TI
4K TOUCHSCREEN

Things I did so far:
Clean W10 Home Install
CPU & GPU Undervolt
W10 Optimization Tweaks


Any help is appreciated.
 

lga1156_ftw

Prominent
Feb 25, 2020
991
104
640
17
Waranty still left right? This is the first way to to contact them

Did you let windows update the gpu drivers or did you use drivers from DELL site?

Since this happens between c-states (not during heavy load) you can try few things

Block sleep: for temporary fix while working on the solution. On startup press F2 to enter bios, under power management settings (might be different for you) there is "block sleep" option , enable that and press f10 to save the bios options.

Disable c-states completely: this will completely drown your battery since your laptop will be ALL the time clocked high, like you where gaming 24/7, not really ideal but worth a try if we try to figure the real solution, You can do this in bios. Disable c-state control, f10 to save.
 
Last edited:

Hyziu

Honorable
Mar 22, 2015
10
0
10,510
0
Waranty still left right? This is the first way to to contact them

Did you let windows update the gpu drivers or did you use drivers from DELL site?

Since this happens between c-states (not during heavy load) you can try few things

Block sleep: for temporary fix while working on the solution. On startup press F2 to enter bios, under power management settings (might be different for you) there is "block sleep" option , enable that and press f10 to save the bios options.

Disable c-states completely: this will completely drown your battery since your laptop will be ALL the time clocked high, like you where gaming 24/7, not really idea but worth a try if we try to figure the real solution, You can do this in bios. Disable c-state control, f10 to save.
Hi,

Much thanks for the comment, unfortunately there is no warranty left - I have the option to buy additional 2 years for £300 and not sure if to go for it.

Also, why did you call the block sleep solution a 'temporary' fix? I haven't done much testing but I'm fairly certain that this has resolved my freezing/stuttering issues.
 

lga1156_ftw

Prominent
Feb 25, 2020
991
104
640
17
It disables sleep Mode completely, if you did not have to disable c state control and only disabled sleep then its not that big issue. Keep testing it for a week and if there Is no More freezing you can close this thread as solved
 

ASK THE COMMUNITY

TRENDING THREADS