Question desktop icons not showing in windows explorer


May 1, 2018
I have new Win10 64bit computer.
My problem is when I go to file explorer and click desktop on the left, none of my desktop programs, files, etc... appear and on the right side "folder is empty"
If I type "shell:desktop" in address bar they do show.
What I am wanting is in file explorer when I click desktop, icon, files, etc... will show.
Thanks in advance.


Which icons? Clicking Desktop normally shows only those icons manually added to the desktop by the currently logged in user; these are the ones contained in the Users/[username]/Desktop folder. Some basic windows icons like This PC, Control Panel, Libraries, Network, Recycle Bin that are turned on or off in the Settings, Personalization, Themes, Desktop icons menu don't normally appear in the Desktop folder. You can drag and drop them from the Shell Desktop folder to create a link in your personal desktop folder. Also, icons added by installed for all users programs are placed in the Users/Public/Desktop folder so they also don't normally appear in the Desktop folder. These can be moved or copied to your username desktop folder so they would appear there.
Did you try dragging and dropping the ones you want from the Shell Desktop file list into the This PC>Desktop folder? (BTW the This PC>Desktop folder is actually the Desktop folder of the currently logged in user.) You should get an entry with a Shortcut suffix which you can then Rename to the shorter name. Also the ones in the All Users folder are normally the same ones in the Public folder.
Last edited:

Latest posts