Question Desktop Internet slower than other devices

DJxTimeKiller

Commendable
Feb 22, 2017
7
0
1,510
0
My desktop download speed is significantly lower than other devices. Whether they are on Wi-Fi or Ethernet cable does not seem to matter. Phone and tablet on Wi-Fi are getting over what I’m paying for. Same for PS4 & Laptop, except they are directly connected to the router with ethernet cable. For some reason my desktop is getting less than half of what other devices are. It does not seem to matter whether I’m using Ethernet cable or Wi-Fi. I have tried switching and getting new cables. I have disconnected the router and connected the desktop directly to the modem. I have checked task manager to see if a program is hogging all the internet. No luck there. The only thing I can finger is that it's some type of software problem.
I have read some people had the same problem and the answer had something to do with AMD software. But I do not have any AMD Software or hard were on my desktop.
Well that’s all I can think of. Any ideas would be greatly appreciated.
 

DJxTimeKiller

Commendable
Feb 22, 2017
7
0
1,510
0
the cpu and board with others to router also .
Processor: Intel i7-6950X CPU

Board MSI X99A: Power Gaming titanium

Lan Card is integrated to Motherboard

Modem: Arris SB6183

Router: Netgear Nighthawk (not sure witch one exactly)

Xbox One, PS4, & desktop are connected to router buy ethernet cord.

As of right know the only Wi-Fi device connected to router is Phone

Let me know if you need anything ells. Ill be doing my best to keep an eye on the conversation
 

DJxTimeKiller

Commendable
Feb 22, 2017
7
0
1,510
0
i would check the network settings for the lan card you have a gigabyte one so youshould have good speed .
I did some research on the network settings. I really did not know what settings where best. So I did what a few tutorials did with no luck. Any chance you can tell me exactly what settings I should be using. Or point me in the right direction on getting that info. Otherwise the settings are not the problem.
 

DJxTimeKiller

Commendable
Feb 22, 2017
7
0
1,510
0
I did what I could using what you gave me. There has been no improvement. The settings where not exactly the same but close. For example

Interrupt moderation - High or if possible extreme I only have the option to enable or disable it.
Link speed and Duplex - maximum value. Did not have this one, I do have Link Speed Battery Saver.(not sure why my desktop has battery options) And it only lets me enable and disable this one.

At lest i have learned a few things about my computer. My Network adapter is Intel Ethernet Connection (2) I218-V. The WiFi adapter is Intel Dual Band Wireless- AC 8260. The problem happens on both WiFi and Ethernet connections. But I'm mostly concerned with the Ethernet.

Sorry my lack of knowledge is slowing this down. I thank you for all your help. It is a learning experience for me.
 

ASK THE COMMUNITY