Desktop suddenly lost internet connection


Nov 10, 2011
My family's main computer, a 4-year-old Dell Inspiron desktop, suddenly lost its internet connection today. The computer is directly connected to a Medialink wireless router hooked up to the modem because the computer lacks wireless capability. The router is working just fine, as we still have our wireless network and can connect to the internet from every other device in the house. The modem is working (a bit obvious). Network and Sharing Center claims to have local connection, but I'm not so sure - I can't access the router settings from a browser, which I'm sure I can do without an internet connection. I take this to mean the computer can't communicate with the router, so I tried swapping out the cable without luck. I also tried using a different port on the router.

I still need to test the router ports by connecting my laptop to the router, but I'm guessing this isn't the problem. Could the problem be the computer's network card?

In the meantime, I'm trying to use a Medialink USB wireless adapter that I actually bought to use with an old Linux desktop. It works fine with Linux and installed perfectly with Windows XP, but for the life of me I can't get the driver to install with Vista. This isn't exactly relevant to my original question, but if anyone has experience with a similar issue, advice would be greatly appreciated here as well.

Edit: I did finally get the driver installed, although it took no less than 10 attempts. Now to make it play nicely with McAfee...

Edit 2: Just to confirm, I tested the router with my laptop and the cable/ports are working. Since no network settings had been changed on the desktop computer, I'm still suspecting the network card, but I'd like someone to confirm my suspicions with some sort of test.

Edit 3: I booted an Ubuntu Live CD to see if I could connect via ethernet, and I can, so it isn't the network card. I'd already looked at the network settings to see if anything caught my eye, but I didn't notice that anything had changed. Any ideas? Are there any command prompt commands I can run to try to pinpoint the problem with the ethernet connection?

Edit 4: I shut down the computer overnight while I slept, and when I booted it this morning the ethernet worked. I still have no idea what was wrong or how it fixed itself, but at least the problem is solved (for now, anyway).