Question Desktop wont boot when both M.2 and Hdd are connected

Apr 17, 2021
2
0
10
0
I'm currently building a desktop for my mom, but right now it has me stumped. The components are as follows...
Ryzen 3 3200g
Asrock b450m pro 4
G skill 2x 4gb ddr4 2400(in first and third slot)
Wd 500gb m.2
Wd 2 tb hdd

The first boot went great. I Installed windows 10 on the m.2 the via usb and then shut it down. The second attempt it would not boot...just stuck on a black screen with asrock logo. So I tried going through bios and making sure it was set to boot to the m.2 and still no luck. I ended up removing the m.2 and it booted fine with the windows usb and so I installed the os onto the hdd. I then booted the pc multiple times with just the hdd hooked up and it worked fine. I then reinstalled the m.2 and once again no boot, stuck on black screen with asrock logo. I then wiped the m.2 from bios and tried it again, but no go. I then disconnected the hdd and reinstalled the os on the m.2 and it booted up fine until I reconnected the hdd. I've tried everything I can think of, but I'm stumped. The mobo manual does mention that the sata3 ports cannot be used in conjunction with the second m.2 slot, which shouldn't be the issue, as I'm using the first slot, not second.

I've been searching for an answer online, but haven't found anything. Any help would be appreciated!
 

ASK THE COMMUNITY