• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Desktop won't stay connected to WIFI

Apr 23, 2020
1
0
10
0
I have a Windows 10 PC I built myself which has very recently run in to trouble connecting to the wifi where it will see the WiFi network, can connect to it but then will shortly after (or when I try use the network, I can't tell which) disconnect. Every time I run Windows Network Diagnostics I get the two problems found:
- A network cable is not properly plugged in or may be broken (Detected)
- Problem with wireless adapter or access point (Fixed)
I then have internet for a minute before it drops out again.

I have a new (week or two old) PCI wireless card, we have a new router (about a week old) that works for all other devices flawlessly, and up until yesterday I could use the internet perfectly. Yesterday it became a little patchy so I updated the driver using device manager's automatic scan. It then worked for an hour or two before coming to the state it's in now.

Things I have tried already:
- Restarting my computer
- Restarting the network adapter
- Forgetting the network
- Uninstalling my wifi adapter and then restarting
- Disabling the automatic power management settings for it
- Disabling the Firewall
- Typing things into the powershell (Admin) including a DNS Flush (I think), and a couple things involving netsh I found googling similar issues

I can't try update my driver again or install any new software because I can't connect to the internet.

The router is a BT smarthub 2.
My Wifi card is a "Ubit AX WiFi 6 Dual Band 2974 Mbps AX200 PCIE Wireless WiFi Card with Bluetooth 5.0" from Amazon
My motherboard is Asus H81M-PLUS Motherboard (almost 5 years old)
My OS is Windows 10
My Wifi drivers are "C:\Windows\system32\drivers\" and then "Neywfw08.dat", "Netwfw08.sys", "vwifibus.sys" and lastly "C:\Windows\system32\IntelIHVRouter08.dll"
I believe my ISP is BT/openreach
The router is dual band 2.4/5ghz
My IP assignment is Automatic(DHCP)
My Protocal is Wi-fi 5 (802.11ac)

None of this has changed in between it working and it not working though.

I'd much appreciate any help anyone could offer!!
 

Andrew_72

Reputable
Feb 10, 2016
5
0
4,510
0
I think i've had this issue too. Not managed to find a reliable fix yet though.

My wifi card is exactly the same too I note! I do have the issue on my laptop though which uses different wifi hardware.
 
Your pc has a ethernet connection plug that into the router it will likely work.

Many of these cards where manufactured before the 802.11ax (wifi6) stuff was complete. There were some issues with the early drivers for this chipset, mostly connecting to wifi6 routers. Since this says ax200 this means it likely has a intel chipset. I would download the drivers from intel and see if those work better. Windows 10 pushed a bugged driver in one of their patches so you want to be sure that you are running intel drivers and make sure the option is set to prevent windows from updating hardware drivers.
 

ASK THE COMMUNITY