Question Device was not migrated due to partial or ambiguous match ?/LX-350 dot matrix printer doesn't print

kuhinja

Reputable
Apr 19, 2017
6
0
4,510
0
Hi,
I have the LX-350 Epson printer, I am using a dot matrix printer for the first time and I installed the driver from the Epson page and the default version that windows installs on the first one, however it will not print whatever I send to print.

The device is not faulty because when I manually print a test page via the buttons of the printer itself - it works. But from the computer to the printer it won't. It only shows status Printing and nothing happens after that ?

I used compatibility troubleshooter when installing the driver, where it recognized Win 7 as the optimal environment and didn’t help.

I changed ports, but it didn’t help. I have returned to the default settings for USB currently as stated on this page - USB0001 (Virtual Printer Port):
https://www.epson.co.uk/viewcon/corp...index/KA-01494

The cables are well connected (via USB).

I changed the usb slots, it didn't help.

I reinstalled the driver - nothing.

System File Check (sfc / scannnow) showed that everything is 100% ok.

On the driver properties I found this Event recorded and it seems to be the core of the problem but I don't know how to solve it:
Device USBPRINT \ EPSONLX-350 \ 7 & 1e169a2f & 2 & USB001 was not migrated due to partial or ambiguous match.
Last Device Instance Id: USBPRINT \ XeroxWorkCentre_3025 \ 8 & c73139e & 0 & USB001 Class Guid: {4d36e979-e325-11ce-bfc1-08002be10318}
Location Path: Migration Rank: 0xF000FFFFE000F122
Present: false
Status: 0xC0000719


Googling around - this seems to be a problem related to Windows.

I currently have the Windows 10 21H1 version.

What to do? Thanks
 

Lutfij

Titan
Moderator
If you're working with the LX350, you can find drivers for the printer, here, with Windows 10 set in drop down menu. As a side note, you should install the drivers in an elevated command, i.e, Right click installer>Run as Administrator. Make and model of your motherboard and it's BIOS version. Your OS version seems fine though I am curious, do you see any anomalies with your OS, outside of the printer being missing from the print process? Chipset/USB drivers installed and up to date on your platform?

Can you find the printer in Device Manager? Is it listed under Printers & Scanners?
 

kuhinja

Reputable
Apr 19, 2017
6
0
4,510
0
Hi Luftij and Ralston18, thank you for replying.

I am using the exact same driver mentioned in your link and yes, the device does appear under Printers and Scanners and Device Manager. It all looks like it should work but it doesn't. I haven't noticed any other issues with my OS. Everything up-to-date. I ran the driver with Admin lvl, same thing.

I did some other things in meanwhile. I've installed it on another PC with Win 10. No error there under Driver Event but still no printing is happening. The Printer itself is not showing any errors with blinking lights.





New Driver Event log from the other PC with Win 10:

Device USBPRINT\EPSONLX-350\6&1e169a2f&0&USB001 was configured.

Driver Name: prnms013.inf
Class Guid: {62f9c741-b25a-46ce-b54c-9bccce08b6f2}
Driver Date: 06/21/2006
Driver Version: 10.0.19041.1
Driver Provider: Microsoft
Driver Section: MS_GENERICPRINT
Driver Rank: 0xFF3002
Matching Device Id: CID_MS_GENERICPRINT
Outranked Drivers:
Device Updated: false
Parent Device: USB\VID_04B8&PID_0046\021101603031333280


I've installed OS Windows 7 as well, as I saw in user guide, OS is mentioned up to Win 7. It didn't help. The driver itself when installing shows as well as on the manufacturer website that it can go to Windows 10.

I've changed the data cable just in case, didn't help.


In all three cases, I get this pop-up from Epson Monitor 3


Use the following links to verify/ensure that you installed the applicable printer drivers:

Start with Epson:

https://epson.com/Support/Printers/Impact-Printers/LX-Series/Epson-LX-350/s/SPT_C11CC24001

However, if Epson has discontinued the drivers and/or support then you may have other options.

For example:

https://3d-drivers.com/

https://allsoftdrivers.com/
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS