[SOLVED] 'dhcps Lease host name not found' issue on Archer C24


May 29, 2019
Model: TP-Link Archer C24
Hardware Version: V1
Firmware Version: 1.4.3 Build 201022 Rel.55840n(5553)

62 WARNING 0days, 00:04:38, [dhcps]Lease host name not found.
63 INFO 0days, 00:04:38, [dhcps]Send OFFER with ip
64 WARNING 0days, 00:04:38, [dhcps]Lease host name not found.
65 INFO 0days, 00:04:38, [dhcps]Send ACK to
91 WARNING 0days, 00:07:13, [dhcps]Lease host name not found.
92 INFO 0days, 00:07:13, [dhcps]Send OFFER with ip
93 WARNING 0days, 00:07:13, [dhcps]Lease host name not found.
94 INFO 0days, 00:07:13, [dhcps]Send ACK to
121 WARNING 0days, 01:04:39, [dhcps]Lease host name not found.
122 INFO 0days, 01:04:40, [dhcps]Send OFFER with ip
123 INFO 0days, 01:04:41, [dhcps]Send ACK to
124 WARNING 0days, 01:07:14, [dhcps]Lease host name not found.

[Full System Log Attached]

My System Log is flooded with this message : [dhcps]Lease host name not found. It's happening with all the devices connected to the router. I've also noticed when it happens with an IP, the device with that IP looses internet connection for a short period of time like 30 seconds or sometimes even looses the WiFi signal. My DHCP setting is pretty basic without any modification to the defaults


Most of the time there's 5 to 6 devices connected. Sometimes there's 1 to 2. I have a computer which is connected via Ethernet. The problem can also be seen there. I've tried factory resetting the router and configuring it from scratch. But to no avail, The problem returned after some time later. I've also tried mailing TP LINK and they are yet to respond. Posted it on their forum and no replies so far.

My educated guess is the problem lies within the firmware or might be a bug. The problem is really really problematic when you need a stable connection. Please help me how to solve it if the problem is from my end.

Thanks in advance

: The frequency of the WARNING : [dhcps]Lease host name not found is increasing. New Syslog 2nd attached
Last edited:
Is this causing a issue. I think this is purely the OS on the end device is not returning a name. This is a optional parameter and I see this on none windows devices.