Question Did I brick my board

Feb 24, 2021
1
0
10
0
So I recently got a new psu (start of an upgrade) and thought I might as well put it in my current system. While in there I thought I’d give the cpu some love with a heat sink and fan clean followed by some new Tim. All seemed well till I came to turn it on. Instantly got a code 55 (which is something to do with ram detection) and no post or bios. So I unseated two of the sticks and that error went away. Then I got bios and a message popped up about a change being detected and f1 to setup or f2 to proceed. I choose f2 and waited. Then a message I’ve never seen on my bios screen before “preparing automatic repair”. The pc shut down restarted and this repeated several times with the same error message afterwards a few restarts I got a bsod about kernel security check failure. I thought with the new psu and removing some ram maybe windows was throwing a fit. I also loosened the cpu cooler a tad in case i over tightened it (that didn’t help). In the end I thought well if windows is upset I’ll just repair/reinstall it. Got out the ole usb stick and restarted. I set the boot from usb and the pc just crashes and restarts again. It shows the blue windows icon for a few seconds then nothing. I tried putting my old psu back and all the same messages. I don’t know what to do here as I cant get past boot. I’ve tried taking bios bat out for 10 mins. Using the second bios. Everything I can think of. The last thing I can think is I’ve knackered something while cleaning. My system is an old one now but it’s my only one and was hoping not to have to upgrade main stuff now. Any suggestions/advice gratefully received


Intel i5 3570k
Hyper 212 evo
Msi z77a-gd65 gaming
8gb ddr3 geil black dragon (was 16 but not anymore)
Gtx 1050 ti
2x ssd (120gb and 256gb)
1hdd (1 tb)
Old psu evga 500w
New psu Corsair rm750 ( not x or I variants)
 

ASK THE COMMUNITY

TRENDING THREADS