Did XFX 9600GT works with iBall generic 400w PSU?

Page 3 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.
Status
Not open for further replies.

Aneesh@4GHz

Distinguished
Sep 20, 2009
806
0
19,010
10
Due to unavailability of the xfx 9600gt,I changed the gfx card to a PALIT 9800GT 1GB DDR3,any prob between the psu and gfx card?

And i also i will post the pics of the psu is any one ready to write a small review on it?
 

Aneesh@4GHz

Distinguished
Sep 20, 2009
806
0
19,010
10
oh its my friends and i cannot open it as it voids the warranty,So only external pics!
And i had got the PSU and motherboard.But the gfx card is still travelling and will got it tomarow!

Thanks for ur help shubham1401
 

Aneesh@4GHz

Distinguished
Sep 20, 2009
806
0
19,010
10
Oh no ,I got the gfx card ,Its a Palit 9800GT Green Version 1 gb ddr3 256bit, with 550/900/1350 the reference model has 600/900/1500.Is there any big perfomane loss on the green edn and it doesnt have a pci-e connector ,But i had already owned the psu and cannot return,Is it safe to run on the generic psu,Or safer is to run it with the vip,The VIP 500W GOLD has 18 A on 2 Rails ,I will post the pics later on a new thread!
 

MidKnightSecs

Distinguished
Jan 29, 2009
4
0
18,510
0
LOLZ

I have been runnin an iBest (Compaq) PSU with 12v rated @ 14a for over 2 years now with no issues and it powers:

PNY Verto GeForce 9600 GT 1GB
Athlon X2 2.8 Ghz
4 GB PC-6400
2 Sata2 HDDs (320 + 500 gbs)
2 22x DVD -R DL Burners
Linksys Wifi card
and until an hour ago when I tried to run a Radeon HD 6870 in this rig I also had a Sabrent PCI TV Tuner.

The Radeon even works for a few minutes at a time before auto shutdown, but then it needs 28a on the 12v and as I stated, mine is 14a.

So yes I replaced the GeForce and am ordering a whole new rig in about 10 minutes.

 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS