Question Different BSODs, games crashing without error, slow and unresponsive performance, tearing, why

Sep 17, 2019
9
1
15
0
Hi, where do I start, so much problems. Let me get this out of the way first, I believe compatible hardware should run without issues out of the box, registry changes, all sorts of tweaks in order to fix it doesn't satisfy me even though I did try every possible tweak I could find since I'm desperate.

So with that out of the way let me post my specs:

Asus Strix B350f gaming running latest bios, now I've heard bad things about Ryzen compatibility with this board, but the QVL suggest otherwise
Ryzen 2600x stock cooler, no oc
CMK16GX4M2B3600C18 (on the QVL) running @3200mhz like on the QVL, but same <Mod Edit> happens at default speed
Asus RTX 2060 Super Dual OC 8GB EVO (what a name)
EVGA G3 Supernova 550w
Samsung 860 Evo V-nand 250gb
I feel like HDDs don't matter, those are unplugged during all these troubleshooting ever since I tried a fresh Windows install

So let me list my problems:

-BSODs, mostly page fault in non paged area, NTOSKRNL.exe, IRQL not less or equal, too many of them
-Absolute <Mod Edit> performance, even in BIOS, when I click my mouse on something I can feel a microfreeze and than it loads, even with the lightest apps used in Windows 10, it's just not smooth at all, running Apex Legends takes a while, the first time it runs it's fine, but after a few seconds the lag begins, it's very stuttery, the sound and mouse movement begins to lag also, one interesting thing to note is that when this happens the gpu usage drops to like 20% after being on like 94% which is weird for having only Apex lobby running, runnning the game at low settings full hd as every other competitive shooter I play, every game crashes without errors, at first I thought it was Windows 10 that's the culprit here cause I heard people had lots of problems lately with the updates, wifi not working, bsods, files getting randomly deleted, then I thought maybe Respawn can't make their game work, but too much time has passed and it's not software related I'm pretty sure
-screen tearing, random short "flashes/flickers", I had a black screen a few times also, the monitor led light went from blue to orange, I had to restart my PC, I'm running the game @144fps stable at @144hz vsync off so I don't understand why the tearing would happen, happens in all games ofc
-games crashing without error which happened to me before with incompatible ram that's not on the QVL, all I did was set it default 2133mhz and games ran fine, but performance wasn't the best as Ryzen wasn't that sweet RAM speed so I got new RAM
-when the stuttering in the Apex Legends menu occurs the PSU makes a sound, it's not really annoying, it's not coil whine I guess, but it's sort of hissing and changing depending on if the lag is present or no, testing with another PSU gave the same result, same sound from the PSU, same lag

Things I've tried to fix this:

-tested gtx 1060 that's waiting to be sold, same BSODs and <Mod Edit> performance
-tested CPU on friends PC with only one of my sticks cause his cpu cooler was in the way of the other slots, we did this cause I tried my ram on different slots in my motherboard and my pc wouldn't boot, troubleshoot light indicated a memory problem so I thought what? I have new memory, googled stuff and found out the CPU has an internal memory controller which could cause issues, memtest gave me 6900+ errors almost as soon as I started the test (on the working slots), so basically right, we tested my CPU and my ram stick, so Apex Legends with 8gb ram, it was the most horrible performance I have ever seen in my life, same stutter while entering a game, same micro freezes, same longer lag in menu, sound lag, my friend looked at me and said "what the <Mod Edit> is this", we started a game and it wasn't normal bad performance you would see, let's say your fps goes from 20-25, no no, it went to 120, to 40, to 30, to 65, very big differences (his mbo has the memory on the QVL list aswell) so I thought great! The CPU is <Mod Edit> (worked fine with his CPU), AMD replaced it for me, apparently they tested it and it really is bad, great, but not great, I still have other problems, the RAMs work on every slot now, ran memtest for hours, 0 errors
-tried DDU, installing a recommended driver from Asus, same problems
-tried legit SO MANY <Mod Edit> tweaks in Windows, in Nvidia control panel, in BIOS, I could start working for Microsoft tech support
-tried another PSU that I have waiting to be sold also, the FSP Raider 550w, which I already mentioned, but to keep this clean, I'm mentioning it again

so tl;dr: tested my ram on my friends pc, worked fine, his mbo supports it (QVL), tried a different gpu, tried a different psu, new cpu

Before I bug my friend to rip our pcs apart and test if it's my motherboard that's the problem I want to hear opinions from you guys, maybe someone had a similar experience cause looking around the internet I didn't find many and if I did those people never seemed to fix the problem or just went silent.

Am I just unlucky and AMD sent me another defective CPU? Would be weird cause the pc boots no matter which slots I use now. Maybe the RAM is the problem even though memtest didn't give errors in a couple of hours and it did before 6900+ of them in the first couple of minutes? What I find weird is Asus has multiple QVLs right, listing different ridges, Raven, some other ridge, but not Pinnacle ridge, there's a list that only says b350f gaming memory QVL and it has my ram listed in there, but what <Mod Edit>ing processor did they test this on?

What other things could I try with my friend besides the mbo, maybe ram again?

Please help me, this issue is making me very depressed, after work I just want to relax and play games or work on my music (yes I produce, my soundclo- just kidding lol), but all I end up doing is troubleshooting, googling, watching streamers who somehow never have issues with their PCs, my mind is full of "set vcore voltage to 0.3v, PREFER MAXIMUM PERFORMANCE, VSYNC OFF" I'm so <Mod Edit> sick of it I want to enjoy games again, it makes me want to jam my head through the <Mod Edit> tempered glass panel and stick a 4+4 pin cpu atx down my throat

Here are the temps @Idle:

https://prnt.sc/rr2epn
https://prnt.sc/rr2fjy

Here's idle usage:

https://prnt.sc/rr2g56

And here's the screenshot of the MSI afterburner while playing Apex:

https://prnt.sc/rr2hge

Thank you for taking the time to read this misery
 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS