Question Difficult to diagnose audio crackling and hardware acceleration issues ?

Status
Not open for further replies.

MrSuperhate

Prominent
Nov 10, 2022
13
0
510
System: 5600G, 6800 XT, 4 x 8GB 3600 MHz CL16 RAM, B550M DS3H AC motherboard, GD-F HPJ 750W PSU, SK hynix Gold P31 boot drive

To be clear, audio crackling happens independent of whether hardware acceleration is enabled.

The facts:

1. I get persistent audio crackling when the audio bitrate of my devices is set to low. It almost goes away when set to the maximum bitrate, but will always happen under certain conditions. The most easily repeatable of which is 4K video playback while seeding torrents at only about 500 KB/s. All of my torrents are located on a 7200 RPM HDD and the crackling issues still happen even while playing a video from the NVME SSD.

2. I may have heard some very limited and rare crackling in games in the past, but I can't say conclusively. I just ran a benchmark in Gears 5 while seeding torrents and there was no crackling. Overclocking my 6800 XT's core clocks from 2424 MHz to 2680 MHz and the memory from 2000 MHz to 2150 MHz caused no audio crackling in games at full utilization.

3. I get audio crackling on my mother board's audio port, my case port, and my HDMI output.

4. The audio crackling completely goes away with PCIE bifurcation 2x8 enabled. I accidentally forgot to revert it from 2x8 to x16 when I was troubleshooting this problem a couple of months ago. I never noticed any audio crackling whatsoever during that time period. I did, however have issues with hardware acceleration on 2x8. Speaking of which,

5. I'm having hardware acceleration issues. When hardware acceleration is enabled, for a handful of videos I get visual artifacting. The artifacting always occurs in the same spots on the videos and looks nearly identical. If I am using hardware acceleration on a 4K wallpaper engine MP4 and try to watch a 4K YouTube video in Chrome with acceleration enabled, I get brutal stuttering and hanging. If I play multiple 4K videos (from NVME Gen 3) at once with MPV I get stuttering.

6. I don't have problems with audio crackling or hardware acceleration on the 5600G's integrated graphics.

Troubleshooting steps:

1. The issues are nonexistent on integrated graphics.
2. On PCIE 2x8 the audio crackling goes away completely. But hardware acceleration issues persist.
3. I've tried turning off XMP.
4. I've used DDU to uninstall and reinstall audio and graphics drivers multiple times.
5. Reseating the GPU.
6. I've tried different video players. MPV is the least problematic.
7. I can't completely rule out software or drivers because I haven't done a fresh windows install.
 
Last edited:

MrSuperhate

Prominent
Nov 10, 2022
13
0
510
I've just realized something. x16 is PCIE gen 4 and 5600G is only capable of gen 3. The crackling happens when set to auto, but auto should still default to 2x8 anyway. So why would that cause crackling?

The setting in is located in my Gigabyte BIOS here:
  • Advanced Mode
  • Settings
  • PCIEX16 Bifurcation
I didn't know x16 is the Gen 4 spec, so I had assumed that Auto set my GPU to use the x16 slot fully.

Edit: Actually, I guess PCIE 3 x16 is a thing, which must be what my BIOS is defaulting to. However I just found this reddit thread. Apparently the audio crackling is a known issue.

Does this mean my hardware acceleration problems are for sure a separate issue? Or could it be suffering from the same PCIE bandwidth related issue?
 
Last edited:
Status
Not open for further replies.