Question Difficulty with Corsair iCUE LS100

Feb 25, 2021
1
0
10
0
I have been working with Corsair Support on this, but we haven't made much progress. Any ideas?
Problem: The Corsair LS100 Smart Lighting Kit initially loads up in iCUE but is very slow and laggy to respond to lighting program changes before freezing entirely, going dark and disappearing from iCUE altogether.

Other observations and things I've tried:
  • I also have the Corsair Lighting Node Pro for the LED strips in my computer case and that device works perfectly fine, responding correctly in iCUE and continuing to operate after the LS100 has crashed.
  • When I plug the LS100 into my old laptop to test it runs correctly there. I can change the lighting profiles in iCUE and it functions smoothly, unlike on the new desktop machine.
  • Tried different USB ports, obviously. Same behavior everywhere.
  • Tried full hard drive reformat and Windows reinstall to eliminate any possible software conflicts. Still had the same issue when Windows and iCUE were literally the only software installed.
  • Tried flashing motherboard BIOS to latest version.
  • Are there known USB port issues with my motherboard? How to I check? My other devices have been operating fine, though.
  • Somewhere on a forum I saw mention of conflicts with Nvidia and Gsync - how do I check that?
Thanks in advance for any insights!

My system (built in Sept. 2020):
AMD Ryzen 5 3600 3.6 GHz 6-Core Processor
ASRock B450 Steel Legend ATX AM4 Motherboard
G.Skill Ripjaws V 16 GB (2 x 8 GB) DDR4-3600 CL16 Memory
Crucial P1 500 GB M.2-2280 NVME Solid State Drive
Gigabyte GeForce RTX 2060 6 GB OC Video Card
Corsair 275R Airflow ATX Mid Tower Case
EVGA BR 600 W 80+ Bronze Certified ATX Power Supply
AOC 27G2 27.0" 1920x1080 144 Hz Monitor
Razer Mouse, Keyboard, Mousepad and Speakers
 

ASK THE COMMUNITY

TRENDING THREADS