Question DIMM slots 1 & 3 not working. Replaced mobo and CPU - same problem


Jul 20, 2016
Purchased a Lenovo Legion PC in July. It came with 2x8gb RAM in DIMM slots 2 & 4. Ordered the same 2x8gb RAM direct from Lenovo to add to DIMMs 1/3. Placed new RAM in DIMMS 1/3. PC would not post. Triple short beep 1 minute after turning on. No monitor activity.

To rule out the new RAM as a problem: I tried both sticks of the original ram in DIMMs 1/3, triple beep immediately on power up. No monitor activity, cannot get to BIOS, no POST. Then tried every combination of 1 stick in each slot.
- DIMM slots 2 & 4 work fine with any combination of the 4 sticks.
- DIMM slots 1 & 3 will not work with any combination of the 4 sticks. Same triple short beep immediately after power on. No POST; no BIOS.

Resetting CMOS via removing the battery/holding power for 30 secs and swapping the jumper for 10 minutes did not fix the problem (though I'm wondering how I can confirm the CMOS was 100% reset. There was no indication aside from a dark screen and automatic reboot after I gave up and finally put RAM back in the original DIMM slots).

Someone suggested placing a stick of try in DIMM slot 1 and leaving the computer running for an hour to give the computer time to resolve the RAM config. That didn't work either.

PC came with 1 year of Lenovo Ultimate Warranty so I scheduled a free technician to come and fix the problem. The technician seemed brand new to the field. He slowly replaced the mobo, CPU, and heatsink. A few hours later, the PC would not post at all. The tech had messed something up or connected something wrong. He shrugged and said, "sorry, I struck out today".

After he left, I asked Lenovo to send a senior technician and let the unusable computer sit there to collect dust. 3 weeks later, the 'senior' technician with, when asked, admitted to 1 year experience, arrived. He replaced the mobo, CPU, and heatsink again. After all that, he was able to get the computer to behave exactly how it was prior to the first technician: works fine with RAM in DIMMs 2/4, but will not post with any RAM in 1/3. He was confused - "never seen this before" - and had to get going to his next scheduled repair.

Contacted Lenovo CS. They are now offering to have me send the PC in for repairs and get it back in another 2-3 weeks. It's questionable whether they're going to be able to fix it at all. I'd just return it for a refund if I could, but the 30 day window is long past.

What could the problem be at this point? Any ideas will be appreciated.

Specs -
OS Name Microsoft Windows 11 Home
Version 10.0.22621 Build 22621
System Model 90UX0000US
System SKU LENOVO_MT_90UX_BU_Lenovo_FM_Legion T5 26ARA8
Processor AMD Ryzen 7 7700X 8-Core Processor, 4501 Mhz, 8 Core(s), 16 Logical Processor(s)
BIOS Version/Date LENOVO O5SKT2CA, 8/3/2023
SMBIOS Version 3.5
Embedded Controller Version 1.22
BaseBoard Manufacturer LENOVO
BaseBoard Product 3768
BaseBoard Version SDK0T76461 WIN 3422101023050
Platform Role Desktop
Secure Boot State On

2x 8 GB DDR5-5600
NVIDIA®GeForce RTX™4070Ti 12GB


Jul 20, 2016
Either both MoBos have the same issue, while rare, it has happened; OR there is too high mounting pressure on CPU due to CPU cooler. There have been instances where when you tighten the CPU cooler way down, CPU will have issues detecting and using all RAM.
3 short beeps supposedly corresponds to a system memory error. Does that fall in line with this theory, or would it be unable to detect the presence of RAM in those slots?

This reminds me - both techs seemed to be confused about the their new replacement mobo not having the heatsink backplate and had to detach it from the mobo being replaced.
Last edited: