Question Disable CSM

hritac71

Prominent
Jan 28, 2019
3
0
510
0
Hi, I am trying to disable CSM on my B450m Pro4 but if i turn it off my screen will go black until i clear the CMOS, but still boot to Windows ( for my hackintosh). I had windows installed with bios UEFI mode (not legacy) and ssd formatted as GPT. Tried some random fix i found online and windows became unusable and had to wipe the ssd. With the ssd wiped I still encounter the same problem after disabling CSM.
My gpu is a RX 580 8Gb nitro with R7 1700x, bios version 3.50
 

Colif

Win 10 Master
Moderator
why are you trying to disable CSM?

I have the problem with the b450 pro4 that the system will not boot if i disable csm completely. after a reboot after saving the settings my screen stays black. i can never open the uefi. with older bios versions it worked, but after one of the last update to 3.50 i have the problem.
link

so its a "feature" of the board it seems. But why are you disabling it?

version 3.50 is last bios you can update to as the ones above warn not to install on your CPU. IT appears its also one that caused the problem. You cannot roll back to previous versions as its not supported.
 
Last edited:

mitch074

Distinguished
Finally, while ASrock recommends against updating past 3.50 if you're using an older Zen CPU, they actually still work. You lose a few settings in BIOS but it would seem that in some cases you get slightly better stability and performance through the newer AGESA. My 1400 on a test system didn't complain.
 

ASK THE COMMUNITY