Question Disabledynamictick wierd mouse movement

Feb 9, 2020
23
2
15
0
Hello people. i followed some guides in order to disable HPET in my OS and get an even 0.5 ms timer resolution and better DPC latency by using useplatformclock No | useplatformtick Yes | disabledynamictick Yes. which it worked because i'm getting lower DPC latency. the only problem i have is after setting "bcdedit /set disabledynamictick Yes" i'm getting really weird mouse movement. Like it has some sort of acceleration which makes it really hard to control and be accurate with sometimes especially while gaming, but from what i'm seeing on the internet this is the 'optimal' command to reduce stuttering, latency etc. if i delete the command using /deletevalue i'm getting higher avg. DPC latency and also spikes sometimes, but i'm getting accurate mouse movement which feels alot slower. this command is supposed to be a OS feature which lets the OS stop the timer when nothing is happening on screen in order to conserve power, but this somehow doesn't explain the permanent change in mouse movement when this command is set to the 'optimal' value which is Yes. any clue to why is this happening and is there any workaround around it? are you guys getting the same results by setting the commands i mentioned above? kinda frustrated right now.
 
Feb 9, 2020
23
2
15
0
Yes, i want to keep the current DPC latency that i have but i don't want this horrid mouse movement. I'm also not the only one experiencing this, and yes i tried a different mouse and it doesn't make a difference. can you guys test this command out yourselves?
 
Feb 9, 2020
23
2
15
0
What drivers should i be getting exactly? Last time i tried using DriverEasy to install all my drivers my pc started running slower. Boot time took longer by about a few seconds, DPC latency went up and i started getting stuttering in GTA V so i said it's last time i'm using any software or installing any 'bloat' drivers. I like my PC fresh, the only driver i'm installing its the GPU one
 

x7007

Honorable
Jan 19, 2015
9
0
10,510
0
Hello people. i followed some guides in order to disable HPET in my OS and get an even 0.5 ms timer resolution and better DPC latency by using useplatformclock No | useplatformtick Yes | disabledynamictick Yes. which it worked because i'm getting lower DPC latency. the only problem i have is after setting "bcdedit /set disabledynamictick Yes" i'm getting really weird mouse movement. Like it has some sort of acceleration which makes it really hard to control and be accurate with sometimes especially while gaming, but from what i'm seeing on the internet this is the 'optimal' command to reduce stuttering, latency etc. if i delete the command using /deletevalue i'm getting higher avg. DPC latency and also spikes sometimes, but i'm getting accurate mouse movement which feels alot slower. this command is supposed to be a OS feature which lets the OS stop the timer when nothing is happening on screen in order to conserve power, but this somehow doesn't explain the permanent change in mouse movement when this command is set to the 'optimal' value which is Yes. any clue to why is this happening and is there any workaround around it? are you guys getting the same results by setting the commands i mentioned above? kinda frustrated right now.

Hey, so you say when you disabledynamictick YES your mouse movement is faster but it has like acceleration right?

When it's No or deleted/not exist then you have a better accurate mouse? I feel the same thing.. the question is why is that. something internal with the windows tick clock?

I checked with my friend, also him we tested the command again. and he felt it was faster but had Acceleration, not just faster movement.

if you want to test just delete the command

Bcdedit /set DisableDynamicTick No

Then to remove

Bcedit /deletevalue DisableDynamicTick

This will make sure it's disabled and not exist.

Please reply as soon as you see the message.
 
Last edited:

david slayer

Distinguished
Feb 14, 2012
28
1
18,535
0
I believe 'useplatformtick' should be off, as well as the other 2. that's what i'm doing, and don't notice any mouse problems ingame or on here. MS says they're for debugging only...
Although i have the problem with the timer not rounding up to 1.00, & 0.5. using ISLC by wagnard to monitor & force it to no avail..
i actually just came back to windows 10 on saturday from 7 where it worked fine.

https://docs.microsoft.com/en-us/windows-hardware/drivers/devtest/bcdedit--set
 
Reactions: Honorable55
Feb 9, 2020
23
2
15
0
Hey, so you say when you disabledynamictick YES your mouse movement is faster but it has like acceleration right?

When it's No or deleted/not exist then you have a better accurate mouse? I feel the same thing.. the question is why is that. something internal with the windows tick clock?

I checked with my friend, also him we tested the command again. and he felt it was faster but had Acceleration, not just faster movement.

if you want to test just delete the command

Bcdedit /set DisableDynamicTick No

Then to remove

Bcedit /deletevalue DisableDynamicTick

This will make sure it's disabled and not exist.

Please reply as soon as you see the message.
yes, i already tried that way before you replied and the mouse felt slower and more accurate with the command OFF. havent found a fix yet, just gotten used to it. i also gave up on 0.5ms timer thingy, i feel like it adds more input lag and makes mouse worse. so the only 2 commands i'm using now are disabledynamicktick YES (even if it feels faster,it also feels more responsive so ive gotten used to it) and useplatformclock NO and 500hz mouse polling rate. so my setup is basically BIOS HPET ON, windows HPET OFF and i end up with 0.5013 timer in ISLC. even if its uneven compared to the 0.5 timer you get while having the command useplatformtick YES, i like it better this way more snappier and responsive. sorry for the late response i gave up on finding a solution so i rarely visit these forums anymore.
 
Feb 9, 2020
23
2
15
0
I believe 'useplatformtick' should be off, as well as the other 2. that's what i'm doing, and don't notice any mouse problems ingame or on here. MS says they're for debugging only...
Although i have the problem with the timer not rounding up to 1.00, & 0.5. using ISLC by wagnard to monitor & force it to no avail..
i actually just came back to windows 10 on saturday from 7 where it worked fine.

https://docs.microsoft.com/en-us/windows-hardware/drivers/devtest/bcdedit--set
same here dude. despite not being even 0.5ms timer i actally like it better this way and it doesnt affect my gameplay/performance at all and still getting relatively low dpc latency even with the latesc nvidia drivers which cause big dpc latency. basically every driver after 3.80 does. if i uninstall drivers using DDU my system stays on single digit numbers in latencymon which is insanely good for windows 10 imo
 
Reactions: david slayer

jayjaytan84

Honorable
Nov 24, 2013
2
0
10,510
0
Hey, so you say when you disabledynamictick YES your mouse movement is faster but it has like acceleration right?

When it's No or deleted/not exist then you have a better accurate mouse? I feel the same thing.. the question is why is that. something internal with the windows tick clock?

I checked with my friend, also him we tested the command again. and he felt it was faster but had Acceleration, not just faster movement.

if you want to test just delete the command

Bcdedit /set DisableDynamicTick No

Then to remove

Bcedit /deletevalue DisableDynamicTick

This will make sure it's disabled and not exist.

Please reply as soon as you see the message.
Thank you for your post! With all the guides online recommending to set disabledynamictick YES, I had this command set to YES for yearssss and unknowingly it has been affecting my mouse movement! My mouse movement is now snappy, crisp and is now truly 1 to 1!

I also have useplatformclock, useplatformtick set NO as well, these command gave me the greatest performance gains in FPS and latency.
 

x7007

Honorable
Jan 19, 2015
9
0
10,510
0
Thank you for your post! With all the guides online recommending to set disabledynamictick YES, I had this command set to YES for yearssss and unknowingly it has been affecting my mouse movement! My mouse movement is now snappy, crisp and is now truly 1 to 1!

I also have useplatformclock, useplatformtick set NO as well, these command gave me the greatest performance gains in FPS and latency.
np
 

ASK THE COMMUNITY