Question Disabling Core Performance Boost on Ryzen 2600x when idle

Tony Case

Commendable
Apr 3, 2017
20
0
1,520
1
Hello there.

So recently I've upgraded to 2600x and it is pretty painful to make it work the way I want it to.
With everything set to default, I can see that one of the six core almost always is trying to sit at ~4GHz even when there is nothing else but desktop/browser. This results in almost constant ~1.4v which leads us to 50-60c in idle and 55-65c while gaming.
Yesterday I disabled Core Performance Boost in BIOS to see what will happen and... well, I have stock 3.6Ghz right now. Idle = 35-40c, gaming - 45-55c. I'm using Deepcool Gammaxx 400 (switched from AMD Wraith Prism, both of them are pretty similar in terms of cooling).
And I have two friends, both with Ryzen CPUs - 1700x with Xilence M402 (which should be weaker than the Gammaxx 400 since its fan is only 92mm while the radiators more or less the same) and 2700x with Deepcool Gammaxx 400. Both of them are using default settings, so Boost is enabled in BIOS for both of them (I helped them with selecting components so I know some details). I asked both of them to tell me their temps in idle and, well, both of them reported with 35-40c result.

What I need is pretty simple (although I still don't know what should I do to achieve that): stock 3.6Ghz when idle/surfing/etc (so that I don't go over 40c most of the time) and boosted 4.1Ghz when gaming (with a limit of said 65c). What am I doing wrong if my friends are using their CPUs with default settings and they have 35c in idle, but I can achieve that only with disabled Boost?
 
Minimum frequency at true idle should be about 2GHz with less than 1v. If you are not getting that, something is not set right in BIOS and/or in windows.
You need to set BIOS to auto and use AMD Ryzen balanced power plan in windows. St maximum processor state to 5 -10%. That should calm it right down and temps with it.
 
Reactions: DMAN999

CosmicDance

Proper
Jun 11, 2019
190
40
120
5
Just change your Windows Power Option to Energy Saver.
This limits my Ryzen 2700X to a maximum speed of 2200 MHZ which is fine for browsing, non-gaming etc.
It kicks in straight away so no need to restart.
You might want to change the power plan's advanced options as it does turn your HDD off etc after so many minutes.

You can then just re-enable your boost in the BIOS so it works under demand.

Balanced Power Plan is fine for all purposes including gaming but High Performance will benefit gaming slightly better as it causes the CPU to work at its rated speed without idling.

Andy
 

Tony Case

Commendable
Apr 3, 2017
20
0
1,520
1
Thanks for the responses.
I forgot to add I've been using Balanced power plan.
I've also tried Ryzen balanced but both these plans worked pretty similar - Ryzen master shows that one random core almost always sits on 4.2Ghz and voltage jumps between 0.9 and 1.48 all the time. Average clock of the CPU in idle is 3.8 or so.

After I switched to Power saving plan and enabled Boost I noticed that in idle CPU sits at 2.2Ghz (all cores) while voltage is around 0.8. And in games I can see one or two cores jumps to 4.2Ghz. So, pretty much exactly what I needed.
However after playing the game for 2-3 hours and closing every single app I've noticed that in idle one of the cores sits at ~4.2Ghz, sometimes jumping down to 3.2, while the other five are on 2.2. Ryzen Master has been running in background all that time. After I relaunched Ryzen Master the 6th core went back to 2.2 as well. Maybe this'll help someone.

Anyway right now it seems to be working the way I wanted it to, but I'll keep an eye on it for the next few days just in case.
 

CosmicDance

Proper
Jun 11, 2019
190
40
120
5
Glad to hear it's improved for you anyway.
Each PC system is so complex and unique that there isn't always a fixed solution that works for everyone.

Interestingly the Power Saving plan runs Battlefield V at 2200 MHZ just fine bit GTA V stutters with it.
Shows which games are more CPU dependent and the ones that are less so can still be run whilst saving electricity to a small degree.
 

Tony Case

Commendable
Apr 3, 2017
20
0
1,520
1
I have to reopen this thread.
So far I've discovered that in power saving plan CPU don't like to rise clock from 2200 most of the time, even in CPU-depended scenarios, which leads to stutters in games and stuff.
Right now I have to constantly switch from power saving to balanced when playing and back to power saving when idle. This is, pretty obvious, very irritating.
But in balanced core voltage likes to jump to 1.46 or so while max clock is around 4.25. I'm interested in setting limit to the voltage. Like, 1.4v, so that CPU don't get past that point?
P.S. How does CPU state in power plan works? Max = 100% - 1 core can reach 4.25, Max = 99% - 1 core can reach 3.2... only. What? Why? How?
 
Last edited:

DMAN999

Respectable
Herald
It sounds like you need set the Minumim Processor state to 5 or 10% in the Advanced settings of the Ryzen Balanced power Plan.
Like this:
View: https://imgur.com/IyqHaD3


As for the CPU Voltage that is something you need to set in your BIOS.
And since I have a different MB, I have no idea what BIOS options your BIOS has to do that.
You need to look on the MSI support site and see what options other users with your MB set for their voltages.
You might need to use a voltage offset or set your LLC to a certain setting BUT only someone with your same MB and CPU can determine that.
 
Last edited:

Tony Case

Commendable
Apr 3, 2017
20
0
1,520
1
That's what I have with every plan. I tried 5, 10 or 15 for minimum but none of these helped.

All plans are min5 max100 (max99 is capping clock at 3200 for some reason). All these are idle.
Balanced, Boost is disabled (I'm forced to use this plan for now). Temps are 35c.
View: https://i.imgur.com/mq7W7Eu.png


Balanced, Boost. Temps are 45-62c.
View: https://i.imgur.com/ZfUTPnR.png


High Performance, Boost. Temps are 45-62c.
View: https://i.imgur.com/R3LAHYW.png


Ryzen Balanced, Boost. Temps are 45-62c.
View: https://i.imgur.com/2npsUuC.png


Power Saving (just in case), Boost. Temps are 34c.
View: https://i.imgur.com/Hmod5on.png



I wish I could've had the same results as you, DMAN999.
I'm using auto settings almost for everything (except I disabled PBO to prevent extreme voltages/clock/etc).
 

ASK THE COMMUNITY

TRENDING THREADS