[SOLVED] Disabling Intel SpeedStep wont make my cpu full clock speed?

Jan 6, 2019
5
0
10
1
So My cpu is not running on full clock speed, shouldnt it when SpeedStep is disabled? It stays at 0.80 GHz and I saw that it only goes up when I put my graphic quality to max in my game. But I want to get full performance on lower graphics settings, and even on my desktop it is slow because of this. Is there a way to fix this?, instead of enabling it because I want to gain performance. And by the way if you need any further information to help you solve it I'll be able to give.
 
Jan 6, 2019
5
0
10
1
Alright after further of my research I found out that in my bios that option makes the cpu not be controlled by the power options. So when disabled, the cpu speed will only rise up during very intensive tasks. What I heard on the Internet got me confused because I thought it was about the option in the bios, which does what I stated above. So now I enable speedstep and disable through using a high performance power plan. And my cpu is performing properly. Just wanted to tell people because it was in my bios on this dell laptop.
 
Jan 6, 2019
5
0
10
1
MERGED QUESTION
Question from furkyturkey : "Intel SpeedStep defect?"

My CPU won't stay on max clock speed. When disabling SpeedStep shouldn't it do that? My CPU stays at 0.80GHz, and only goes up when I put my game to full graphics quality. Don't know how I can fix this.
 

Lutfij

Titan
Moderator
List your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

Are you on the latest BIOS update for your motherboard?

Please don't create multiple threads on one topic. It' only muddles progression of thought from the community.
 
Jan 6, 2019
5
0
10
1
 
Jan 6, 2019
5
0
10
1
Alright after further of my research I found out that in my bios that option makes the cpu not be controlled by the power options. So when disabled, the cpu speed will only rise up during very intensive tasks. What I heard on the Internet got me confused because I thought it was about the option in the bios, which does what I stated above. So now I enable speedstep and disable through using a high performance power plan. And my cpu is performing properly. Just wanted to tell people because it was in my bios on this dell laptop.
 

ASK THE COMMUNITY

TRENDING THREADS