Question disabling usb power on shutdown

denver2020

Honorable
Jan 4, 2015
5
0
10,510
0
i have the asrock b450m hdv r4.0.

the usb port keeps my headset (MSI Immerce GH50 RGB lights on even after shut down .
to overcome this i performed below changes
  1. disabled fast startup
  2. disabled all peripherals from waking my computer
  3. and finally changed deep sleep option in bios to enabled tried S5 and S4 & S5 .
strangely after my changes on step 3 (above) , i cannot turn off my computer. everytime i attempt to shutdown, the computer keeps restarting..
i finally had to revert the changes (disable deep sleep) and then the computer doesnt restart automatically.

now what i want is to completely disable power to usb ports. is there any other worknaround?
also any idea why enabling deep sleep makes the computer restart,



thanks in advance
 
Last edited:

Lutfij

Titan
Moderator
What BIOS version are you currently on for your motherboard? What version of Windows 10 are you on? What are the make and models of your mouse and keyboard? Which ports are they populating on the rear I/O of the motherboard? Lastly, what is the make and model of your PSU and it's age?
 

denver2020

Honorable
Jan 4, 2015
5
0
10,510
0
What BIOS version are you currently on for your motherboard? What version of Windows 10 are you on? What are the make and models of your mouse and keyboard? Which ports are they populating on the rear I/O of the motherboard? Lastly, what is the make and model of your PSU and it's age?
Hi Lutfij

Thank you for your response, please find details requested

BIOS Version/Date -
BIOS Version/Date American Megatrends Inc. P4.50, 12/3/2021
OS Version - Microsoft Windows 10 Pro - Version 10.0.19042 Build 19042
PSU - SILVERSTONE ET550-HG (April 5, 2018)
Port plugged in - Tried front and back USB ports - all keep the headset lit after shutdown
Device impacted - One correction to my earlier post- the lights are only active (after shutdown) on my gaming headset
Headset -MSI Immerce GH50

Mouse - Logitec G603 (wireless) No impact
Keyboard - Razer Cynosa V2 - No impact - the lights turn off after shutdown
 
Last edited:
....
now what i want is to completely disable power to usb ports. is there any other worknaround?
also any idea why enabling deep sleep makes the computer restart,
...
Have you tried moving the devices to different USB ports?

A genuine "work-around", but effective, is flip the rocker switch power button on the backside of the PSU. That's actually the safest too as it removes the line voltage from the input of the PSU so power surges can't harm it.

And as far is why the system restarts all I can say is Windows' sleep and 'fast startup' features are, and always have been, a hot mess. They may work right...for a while...then suddenly stop working. I've learned to just disable Fast Start up and disable it's 'sleep after' settings from Power plans. I always do a complete shutdown when leaving it unattended since restarting the system is fast with modern NVME drives, under 15 Sec's usually. I don't have any need for the drama that comes with constant troubleshooting it brings.
 
Last edited:

denver2020

Honorable
Jan 4, 2015
5
0
10,510
0
Have you tried moving the devices to different USB ports?

A genuine "work-around", but effective, is flip the rocker switch power button on the backside of the PSU. That's actually the safest too as it removes the line voltage from the input of the PSU so power surges can't harm it.

And as far is why the system restarts all I can say is Windows' sleep and 'fast startup' features are, and always have been, a hot mess. They may work right...for a while...then suddenly stop working. I've learned to just disable Fast Start up and disable it's 'sleep after' settings from Power plans. I always do a complete shutdown when leaving it unattended since restarting the system is fast with modern NVME drives, under 15 Sec's usually. I don't have any need for the drama that comes with constant troubleshooting it brings.
thanks, yes tried various ports. i got another respons from asrock community to try resetting cmos using the jumper.. will give that a try... guess switching off psu power would be the last resort.
 

ASK THE COMMUNITY

TRENDING THREADS