[SOLVED] Display driver amdkmdap stopped working and recovered successfully

Status
Not open for further replies.
Aug 12, 2019
67
8
45
4
Hello guys, i have recently bought a new RX 5700 XT switching from a gtx 1660 TI and while i am playing the witcher 3 it crashes after loading a concrete scene. The image gets frozen, after that the screen gets black and then it crashes to desktop.
I can play the game everything on ultra at 60+ FPS, i play in borderless window mode, i use V-Sync. But nothing seems to work.

I have discarded PSU problems since i have done stress tests both on CPU and GPU and i got 0 screen crashes. The temps are pretty much good (CPU 55ºC and GPU 65-70ºC), i changed the power plan to max performance, tweaked the performance plan settings a little. I gotta mention that i started testing my cpu to achieve 4.0GHz @ 1.4v and it worked but i decided to not use it anymore because i didn't see any improvement in my gaming experience.

My PC Specs are
CPU: Ryzen 5 2600 3.4GHz (2 months old)
MOBO: Asrock AB350m Pro4 (8 months old)
PSU: Nox Urano VX 650w 80+ Bronze (this does handle the GPU and the whole system perfectly) (2 months old)
RAM: Corsair Vengeance LPX 2400 16gb 2x8 (8 months old)
GPU: Sapphire Pulse RX 5700 XT (4 days old) (Driver Adrenalin 19.9.1)
Monitor: I dont know the exact model but it's an LG (connected by HDMI)

It never happens with any other games (even tho i suffer of some stuttering for some reason). I play at 1080p every single game (don't kill me for having a RX 5700 XT and playing @ 1080p since this is not the main concern). My settings in the witcher 3 are all on ultra (including hairworks and hairworks AA set at 8x).

Thanks in advance

Edit: Tried rolling back to older drivers such as 19.7.5 and it made it much worse
 
Last edited:
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS