Display Driver Nvidia Windos kenel error...


Jan 8, 2013
Greetings everyone and Happy New Year to you all.

Im a Tactical EMT Here on Staten Island, New York. Yes the place hit hard by Hurricane Sandy. In the storm I lost a lot of things including my desktop... and figured this would be a good excuse to invest some money to get a gaming rig. So I bought all the parts needed to build one. Viewed lots of videos and reading here on TH for what is compatible etc.

When it comes to saving a life or dealing with a bloody wound, I know exactly what to do with my eyes closed. When it comes to computers... im not as gifted so Im hoping someone here has an answer for me.... because Im sooo frustrated.

Before I even get into the issue, do know I searched google and especially here for a resolve... but have not resolved the issue so Im hoping I could ask.

First System Specs:

Thermaltake Chaser MK-1
Intel i5-3750K
Asus P8Z77-V LK
Corsair H100i Cooler
16GB Corsair Vegeagence 1600 DDR3 RAM
Gigabyte GTX 670 Factory OC 2GB
Samsung 840 Pro-Series 128GB SSD
Corsair HX750 PSU
Windows Home Premium OEM

Initially I did a out of case set-up before installing. CPU, Mobo, graphic card. Started it and I was able to see the messaging on the screen. So I disconnected and installed everything. Powered up and installed windows! Hurray!!!

I initially only installed the LAN drivers from my mobo disk so I can then install all the latest drivers for everything from online as most suggest. That worked well. Installed the latest driver from Gigabyte for the graphic card... and the screen now looked correct. before it everything was at a default setting big and clunky. So I was happy.

I did not install anything else... no programs, no games or anything. I made a System Image back-up and then went to download and install Corsair's LINK program for my Corsair cooler. While navigating in explorer to the Corsair site I notice the mouse was sluggish. It would freeze for a second or who. this would happen a couple of times and then I get a screen blackout for 2-3 seconds. After the screen comes back on I got the following error message at the bottom of my screen:

Display driver stopped responding and has recovered.
Display driver NVIDIA Windows Kernel Mode Driver Version 310.90 has stopped working and has successfully recovered.

I figured maybe it was because I just installed the driver. So I continued on with getting to the corsair site. I got to the site and it started again, mouse acting up and this time the screen went black.

I shut down the system. Waited a few minutes and I noticed it again. I watched part 3 of Neweggs How to Build A PC again... especially the installing windows and drivers etc and re-did every step. Reformatting my SSD, re-installing Windows and the drivers. And I still get the issue.

I then retired it with using only the disks that I got with the products. Still have the issue.

I even tried it after installing all the Windows updates and still have the issue.

So I tried a lot of the ways I read resolutions for... I checked the Geforce forums as well... Restore to old driver... update to new driver... remove and re-install driver... turn off system for 1/2 hour etc. And still I have the issue.

In the divice manager, everything seems to be ok. I checked the graphic card and it says working normally.

So Im really at a loss here.

I was debating buying a pre-made system as I normally would but heard so many horror stories with the Gaming system providers... I decided to build my own. and Im 99% there. I just cant figure out this issue.

I cant do anything without it freezing up and blacking out.

Can anyone shed some light on this issue?

Thank you!!



Jan 8, 2013
I forgot to mention my temps are low... 32-33 degrees. So its not overheating.
My CPU is almost 24 degrees. mobo temp is 22


Jul 15, 2012
Hi there... You are not the only one experiencing this issue.

I got EVGA 650 Ti SSC and it keeps crashing after 10 minutes of playing Diablo 3. The same message is displaying to me as well. Although I was using older driver .70 and now updated to new .90, the problem is still here. As far as I managed to do is to find a few links which might help you:


The problem seems to have something with nvidia Physx, but I am not sure. I can't bother with drivers anymore... I just hope that nvidia will resolve this issue as soon as possible.