Question Display froze, now black-screens on start-up and monitor can't find any input devices.

Crazy_Steve

Reputable
Dec 29, 2015
38
0
4,530
US
My friend and I were just playing a game and his game froze. He tried alt-tab'ing, alt-f4'ing, ctrl-alt-del, all the works, and nothing changed on the display. So he shut down his computer using the power button, however, the computer had shut down from a press of his power button, not a hold (Mentioning because this is odd). Now upon startup the monitor can't find any display signal. We've tried HDMI and DVI, neither work. We've tried attaching his GPU to my TV and nothing, no input detected. We've also tried plugging my PS4 into his monitor, and it worked fine.

Sounds like it's a dead GPU however the card still lights up so I'm not quite sure how entirely dead, we were hoping just a fried port or something but it seems like it's the card.

Integrated graphics black-screens too, it always has for him for some reason.

Specs are:
CPU: 6600K
MB: ASRock H170a-X1/3.1
GPU: EVGA 1070 SC
More can be provided but these are the biggest things ¯\(ツ)
 

Crazy_Steve

Reputable
Dec 29, 2015
38
0
4,530
US
light up doesn't mean it work. take it out and test the gpu on another pc

make and model of the psu?
Yeah, I imagine the GPU lighting up is really only a sign of power delivery, nothing really more important than that. Don't really know why I wrote that, I know better : p must've just been desperate for it to be okay.
PSU is an EVGA 750W 80+ Bronze, possibly more formally known as the Supernova 750 B2.
 

ASK THE COMMUNITY

TRENDING THREADS