Question Display not being recognized by GPU HDMI, GPU DisplayPort, or MB HDMI

Sep 24, 2019
2
0
10
0
Built PC one year ago. Went into office tonight and nothing displaying on monitor using HDMI or Display Port on GPU. Then:

  1. Tried motherboard HDMI
  2. Removed GPU and tried motherboard HDMI again
  3. Removed RAM in slot 2
  4. Swapped RAM in slot 1
  5. Held in mb reset button for 5 seconds
  6. Removed mb battery for 5 min, tried mb reset button again
  7. Tried different display and cords
MB is flashing CPU LED and sounds one long beep followed by two short beeps. Figured I'd try replacing motherboard next. Thoughts?

Specs:

AMD RYZEN 5 2600X 6-Core 3.6 GHz (4.2 GHz Max Boost) Socket AM4 95W YD260XBCAFBOX Desktop Processor

MSI PERFORMANCE GAMING X470 GAMING PLUS AM4 AMD X470 SATA 6Gb/s USB 3.1 HDMI ATX AMD Motherboard

CORSAIR Vengeance LPX 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 3000 (PC4 24000) Memory Kit Model CMK16GX4M2B3000C15

MSI Radeon RX 570 DirectX 12 RX 570 ARMOR MK2 8G OC 8GB 256-Bit GDDR5 PCI Express x16 HDCP Ready CrossFireX Support Video Card

Mushkin Enhanced Pilot M.2 2280 500GB PCIe Gen3 x4 NVMe 1.3 3D TLC Internal Solid State Drive (SSD) MKNSSDPL500GB-D8

EVGA 650 GQ 210-GQ-0650-V1 80+ GOLD 650W Modular EVGA ECO Mode Power Supply
 
Last edited:
Sep 24, 2019
2
0
10
0
Forget about motherboard video out connections, your CPU doesn't have IGPU so they wouldn't work anyway.
Your RAM should be in A2 and B2 slots only.
Try GPU in another PCIe port.
Replug all power connections.
Ah, didn't realize the motherboard video out connections wouldn't work, thanks. So issue could be GPU afterall... I'll try a different slot and power connections. RAM is in correct positions.
 

ASK THE COMMUNITY

TRENDING THREADS