Question Display not showing.

Astrix008

Prominent
Oct 26, 2019
35
2
535
0
I have just now changed my motherboard from b85 to h81.
So, now when I'm starting my pc everything works fine like cpu fans, sys fans and graphics card fans are all rotating fine but my display is not showing anything..
 

egda23

Prominent
Jun 14, 2020
684
123
640
20
I have just now changed my motherboard from b85 to h81.
So, now when I'm starting my pc everything works fine like cpu fans, sys fans and graphics card fans are all rotating fine but my display is not showing anything..
  1. are you sure to have connected your monitor to the GPU and not to the motherboard ?
  2. you just use the same HDD / SSD with Win 10 as it was without new installation ?
 

egda23

Prominent
Jun 14, 2020
684
123
640
20
Yes i have connected the display to the GPU and i am using my previous hdd and ssd drives. Is there a problem?
With such a radical change (the mobo), the effect on Win 10 is unpredictable, it could boot without problems and automatically install new chipset drivers, as it could simply refuse to boot.
It that case, it means a complete fresh installation of Win 10.
But first thing first, I would recheck all the connections especially the boot drive
 

Astrix008

Prominent
Oct 26, 2019
35
2
535
0
With such a radical change (the mobo), the effect on Win 10 is unpredictable, it could boot without problems and automatically install new chipset drivers, as it could simply refuse to boot.
It that case, it means a complete fresh installation of Win 10.
But first thing first, I would recheck all the connections especially the boot drive
How do I format it, I can't see display on my pc.
 

Astrix008

Prominent
Oct 26, 2019
35
2
535
0
Umm....my previous motherboard had 8pins for cpu connecter but because it was 5 years old mobo and I couldn't get that same mobo so , i had to get a 4 pin motherboard......could that be an issue?
 

egda23

Prominent
Jun 14, 2020
684
123
640
20
still no display
let's cool down
So, you have taken the GPU out ?
Disconnected all HDD / SSD ?
And when you boot there is no display at all ? nothing, no signal ? black screen ?
At that point, do a clear CMOS (take out the cell battery on your motherboard for a few minutes). Put the battery in place, and boot.
If still nothing, I am afraid that you could have a hardware problem.
100% sure that your monitor is working ? Tried another cable ?
Try with a single RAM stick
If sill nothing, it could be a motherboard or CPU problem
 

Astrix008

Prominent
Oct 26, 2019
35
2
535
0
let's cool down
So, you have taken the GPU out ?
Disconnected all HDD / SSD ?
And when you boot there is no display at all ? nothing, no signal ? black screen ?
At that point, do a clear CMOS (take out the cell battery on your motherboard for a few minutes). Put the battery in place, and boot.
If still nothing, I am afraid that you could have a hardware problem.
100% sure that your monitor is working ? Tried another cable ?
Try with a single RAM stick
If sill nothing, it could be a motherboard or CPU problem
Yeah I checked my monitor it's fine, it's working on my laptop, I have just one 8gb DDR3 ram. And I have changed my motherboard today, so that could be an issue....and wanted to ask , can this be a thermal paste issue , might be its not applied correctly.? And is there a way I can check my processor if it's working or not?
 

egda23

Prominent
Jun 14, 2020
684
123
640
20
Yeah I checked my monitor it's fine, it's working on my laptop, I have just one 8gb DDR3 ram. And I have changed my motherboard today, so that could be an issue....and wanted to ask , can this be a thermal paste issue , might be its not applied correctly.? And is there a way I can check my processor if it's working or not?
I don't believe in a thermal paste problem.
The "new" motherboard is second hand ? Are you sure it was in working condition ?
 

Astrix008

Prominent
Oct 26, 2019
35
2
535
0
I don't believe in a thermal paste problem.
The "new" motherboard is second hand ? Are you sure it was in working condition ?
No, motherboard is first hand, I had to downgrade my motherboard because the one that i had has been discontinued. I got the product from Amazon. And I don't know if the motherboard was in working condition or not. So , I have already applied for a refund.
 

egda23

Prominent
Jun 14, 2020
684
123
640
20
No, motherboard is first hand, I had to downgrade my motherboard because the one that i had has been discontinued. I got the product from Amazon. And I don't know if the motherboard was in working condition or not. So , I have already applied for a refund.
When your B85 mobo failed, are you sure it was the mobo and not the CPU ?
 

ASK THE COMMUNITY

TRENDING THREADS