Display Port Adapter


Dec 7, 2010
Good Evening All,

I have a really weird problem at work pertaining to the Display Port adapters we use for our VGA monitors. I have had this particular workstation for over 9 months now and did not have any trouble with it until a month ago. The DP->VGA adapter we were using was determined to be the culprit, as replacing it restored my display. A week later, the monitor goes out again. Not wanting to waste resources, I tore apart the old adapter to see if there was a short. Sure enough, the old adapter had several exposed ground wires soldered to the pins on the PCB of the adapter module, which appeared to be touching. Separating these exposed wires, connecting it again yielded a functioning display. I used the original adapter for another three weeks or so before it went out again today. Re-attempting my previous fix, I again separated the grounds and plugged it back in, no dice. I then went to my IT guys and asked for yet another adapter. This one, made by HP, was brand new in the static wrap. Plugged it in, no dice. On a hunch I plugged in adapter number two. Viola! It worked! :eek: I did tear apart adapter 2 but it was a sealed unit, which I could not access without breaking what appears to be a common ground surrounding the unit, not something I want to do. So, I closed that one back up.

There is no visible difference between adapter 2 and 3, and we even tested adapter 2 and 3 on another machine, which both worked. My question is: is there a situation where there could be a short on the motherboard where one adapter will work and the other will not?

Thanks guys!

I will award ten bouncies to the correct answer... :bounce:


Jan 21, 2013
Had what sounds like a similar problem, second display running extended desktop attached to HP PC via display port adapter, would regularly lose signal after computer was locked and then logged on again.

We tried a HP display port adapter and a USB display port adapter (tried a couple of each to be sure) but it made no difference. Monitor worked elsewhere, and display port adapters were working elsewhere.

After updating the graphics drivers, it was fixed.