[SOLVED] Display Port connection not working

RacAtat007

Distinguished
Aug 8, 2012
189
4
18,695
2
I have been using a TV as a monitor through HDMI for a long time so I bought a MSI Optix MAG271C monitor and went to set it up today using DP but my GPU (RTX 2060) won't recognize the DP adapter, I can get it to work using HDMI just fine. I tried 2 different cable with the same result. I've looked online and followed what I could find but the GPU doesn't even seem to show the cable is connected. I read somewhere it may have to do with the fact the monitor is freesync and I'm using an NVIDIA GPU but there's no setting to turn it off on the monitor. I'm stumped, any help would be appreciated
 

boju

Champion

RacAtat007

Distinguished
Aug 8, 2012
189
4
18,695
2
Disconnect all video cables and power cable from monitor and let sit for 5~10 minutes.
I did this and it didn't do anything. The GPU won't show the DP is even plugged in so I can't select it as a video source. When I plug back in the HDMI it automatically switches to it.
 

boju

Champion

RacAtat007

Distinguished
Aug 8, 2012
189
4
18,695
2
Make sure Displayport is properly connected and locked in both ports with it's locking teeth, shouldn't easily be pulled out like Hdmi.

Disconnect Hdmi cable completely from monitor and graphics card.

See the op's edit and what he did.
https://www.reddit.com/r/Monitors/comments/bhtbvb View: https://www.reddit.com/r/Monitors/comments/bhtbvb/msi_optix_mag241c_displayport_not_working_but/?utm_source=amp&utm_medium=&utm_content=post_body
I'll try again but it sounds like his issue was the monitor not picking up the signal, mine is the GPU doesn't output anything because it's not showing it's plugged in. I have the same GPU and monitor as the post so it can't hurt
 

boju

Champion
Try power down the computer for the same amount of time. Hopefully by resetting monitor and fresh boot completes the negotiation between gpu and monitor.

If you don't get a display try boot the pc first followed by the monitor a few seconds later.
 
Last edited:

boju

Champion
So you tried this exactly?

Power down both pc and monitor (disconnect power cable from monitor) for 15mins.

Disconnect all video cables from pc and monitor.

After 15mins, connect only Displayport cable. Plug power back into monitor.

Turn pc on then monitor 3 seconds later.

--

Both ends of the Displayport cable do lock in properly?
 

RacAtat007

Distinguished
Aug 8, 2012
189
4
18,695
2
So you tried this exactly?

Power down both pc and monitor (disconnect power cable from monitor) for 15mins.

Disconnect all video cables from pc and monitor.

After 15mins, connect only Displayport cable. Plug power back into monitor.

Turn pc on then monitor 3 seconds later.

--

Both ends of the Displayport cable do lock in properly?
Yeah both cables lock in fully but idk if it was fully 15 min. I have some laundry to do soon so I'll try it then and report back
 

RacAtat007

Distinguished
Aug 8, 2012
189
4
18,695
2
So you tried this exactly?

Power down both pc and monitor (disconnect power cable from monitor) for 15mins.

Disconnect all video cables from pc and monitor.

After 15mins, connect only Displayport cable. Plug power back into monitor.

Turn pc on then monitor 3 seconds later.

--

Both ends of the Displayport cable do lock in properly?
So I tried everything last night with no luck and gave up deciding to just use HDMI. I had the HDMI and DP both connected when I powered off the PC and went to bed. This morning I turned the PC on and it just defaulted to DP lol. I don't understand because I tried turning it off for almost and hour last night but it's working so I'm not going to question it. Thank you for taking the time to help.
 

ASK THE COMMUNITY

TRENDING THREADS