Question Displayport is working but suddenly stopped working after PC restart using RTX 3070.

Oct 4, 2022
9
0
10
0
Hi all, recently got my hands on a Zotac 3070 and have used it on my dual monitors pretty smoothly for 3 days and then suddenly DP stopped working on my main monitor after a restart and only the HDMI port send a signal on my secondary monitor. I also tried the DP port on my secondary and still no display. None of the DP ports are sending signal yet my main monitor recognizes that a DP cable is connected.

So far I have tried different cables, different monitors, updated drivers and bios, reseated GPU and RAM, unplug power cables both monitors and PC. I also checked if all connections are tightly secured. Right now I'm using HDMI on my main monitor and my secondary is on standby since my GPU only has 1 HDMI port.

Note: My Zotac RTX 3070 is undervolted/overclocked thru MSI Afterburner before this happened but everything is still working fine and I can play games.

Specs:
Ryzen 7 2700
Zotac 3070
MSI B450M Mortar Max
Seasonic Core 550W Gold
NVIDIA Driver 517.48
LG 27GL850 Main (DP) / Dell Ultrasharp 27 Secondary (HDMI)

I've been troubleshooting this for 5 days already and I'm so lost right now. Please help me.

Edit 1: Forgot to mention that I already rolledback my GPU, reinstalled Windows 10 with fresh drivers and updated my bios to the latest version and still the issue persists :( AFTER doing this I've seen a quick white horizontal lines flashing in my monitor while BOOTING.

UPDATE: I already lost hope and assumed it could be a bad GPU/PSU but displayport suddenly WORKED again out of nowhere and when I turned off the PC, it STOPPED working AGAIN for the second time. I redid all the troubleshoot and possible fixes that I mentioned and can't get it to show any signal again. I'm back to HDMI for now.
 
Last edited:

Lutfij

Titan
Moderator
Zotac 3070
Seasonic 550W GOLD

Even if your PSU was brand new, regardless of asking what the age of the PSU is, you're severely underpowered for that build with an RTX3070 in there. You're advised to look into an 850W or higher wattage, reliably built PSU to power a build with an RTX3070 in it.
 
Oct 4, 2022
9
0
10
0
Zotac 3070
Seasonic 550W GOLD

Even if your PSU was brand new, regardless of asking what the age of the PSU is, you're severely underpowered for that build with an RTX3070 in there. You're advised to look into an 850W or higher wattage, reliably built PSU to power a build with an RTX3070 in it.
It's not displaying thru displayport just because of PSU? But it was working before and I can still play games smoothly right now using hdmi. I just can't use the displayport or is it really that demanding for power? Btw my CPU is not overclocked and I also changed my GPU back to stock and it's still showing blackscreen on displayport.
 

Fatblabs

Prominent
Jun 29, 2021
286
12
695
1
It's not displaying thru displayport just because of PSU? But it was working before and I can still play games smoothly right now using hdmi. I just can't use the displayport or is it really that demanding for power? Btw my CPU is not overclocked and I also changed my GPU back to stock and it's still showing blackscreen on displayport.
Use a higher watt psu first, it could be the base of your issue
 
Oct 4, 2022
9
0
10
0
Go to NVidia control panel>Display>Set up digital audio. Is the monitor connected with DP cable listed there?
Go to Device Manager. Is the monitor connected with DP cable listed there?
Already checked it before, both are not showing DP cable.
 
Oct 4, 2022
9
0
10
0
Then it seems to me like a GPU failure. I suppose there is a specialized chip that converts signal from GPU to all DP ports and if it died then all DP ports would stop working just as you experience.
This is the first time I've heard of this and that seems unlikely to happen overnight. All 3 DP ports went bad suddenly after a restart?
 
Oct 4, 2022
9
0
10
0
Why not? All electronics fail unexpectedly. There is absolutely nothing strange in this happening overnight - actually it most likely happened when you turned PC on next day.

If there is just one chip converting signal to all ports then yes.
I've been reading a lot of forums related to my issue and I'm also assuming if my cables are just completely bad. Some people said cheap cables can cause many issues and make you GPU look dead and I'm pretty sure I'm using cheap HDMI and DP cables that you can get for $3-5. I don't want to get a brand new PSU or GPU out of nowhere without knowing the root of the problem. I also still haven't tried my GPU on other system if the DP will work (will do this soon).
 
Oct 4, 2022
9
0
10
0
Why not? All electronics fail unexpectedly. There is absolutely nothing strange in this happening overnight - actually it most likely happened when you turned PC on next day.
Displayport suddenly WORKED again but stopped working after rebooting the PC. Do you have any guess what could be the root of this problem?
 

DRagor

Illustrious
Displayport suddenly WORKED again but stopped working after rebooting the PC. Do you have any guess what could be the root of this problem?
Most likely that could be caused by bad cable but you mentioned you tried different cables. I assume by that you mean more then one DP cable so it would be rather unlikely to have same problem with few cables. Just in case if possible try yet another DP cable though.
When it worked again, was the display completely normal? Nothing strange about it?
 
Oct 4, 2022
9
0
10
0
Most likely that could be caused by bad cable but you mentioned you tried different cables. I assume by that you mean more then one DP cable so it would be rather unlikely to have same problem with few cables. Just in case if possible try yet another DP cable though.
When it worked again, was the display completely normal? Nothing strange about it?
I only tried 2 cheap displayport 1.2 cables, what I mean is, those black generic looking displayport cables that are around $4-5. Could be bad cables+++?

When it worked again, both monitors were completely fine but I didn't try any games. I just rebooted the PC to see if everything is back to normal again with the DP cable but then never showed any signal for the 2nd time.
 

ASK THE COMMUNITY

TRENDING THREADS