Question DisplayPort no signal?

frosche

Commendable
May 6, 2018
9
0
1,510
0
Hello,

So I am having some issues in regards to my DisplayPort having no signal and I can't tell what is causing it. I run a VG248QE and I've had it for 6 years but it still works fine with my DVI-D cable.

I've got the DisplayPort to work rarely when I have unplugged the power cord on the monitor and the DisplayPort cable on both ends for both for a minute then plugged them back in but now it doesn't seem to work at all. This issue started when I put my computer to sleep mode and I turned it back on noticing the DisplayPort no signal issue.

I have also noticed an issue where there was an automatic pc restart randomly where there was a lapse (.3 seconds or even less before pc turns back on) when I have unplugged the power cord of my DisplayPort. This is an uncommon occurrence though. Not sure what this issue is about or if it's related to the main issue at hand but just some more information just in case.

I've had the DisplayPort cable for a few months now, I believe I had the same issue at the start when I first got it but I forgot how I fixed it (might even be the one I tried as stated earlier) but now the issue has cropped up randomly now when I turned my pc on from sleep mode and it won't work with either turning the pc on and off fully or in sleep.

I'm open to help and thanks in advance. Let me know if you guys need more information that I might have missed.

Some of my specs are :
PSU - Phanteks AMP Series 750W
CPU - AMD ryzen 5 3600x
GPU - Geforce 2080 Super
MOBO - MSI B450M PRO-VDH MAX
 

Lutfij

Titan
Moderator
What BIOS version is your motherboard on at the time of writing? You should cross reference MSI's support page for your motherboard to see what the latest BIOS version is. If you have a number of updates to go through, graudally work your way to the latest BIOS as opposed to jumping to the latest BIOS version. Also, update the BIOS manually, not via the Dragon Center app(if that's what you're using).

You might want to also share the age of the PSU. What OS version are you currently on? We're on version 20H2. Also, have you tried reinstalling your GPU drivers after using DDU?
 

ASK THE COMMUNITY

TRENDING THREADS