Question Displayport not working Geforce RTX 3070

Dec 4, 2020
2
0
10
0
Hi all,
I recently upgraded to a 3070

I uninstalled my 1070 drivers, shut down, plugged in the new 3070 and booted windows. When I first plugged it in with the displayport it was working, booted up and went into windows. I installed the drivers through Geforce experience and when it was completed the screen went black. I have been unable to get the displayport connection working since
HDMI connection works, so the monitor is fine
Things I've tried;
  • uninstalling everything nvidia and re-installing - no luck
  • uninstalled everything nvidia related using DDU (twice) - no luck
  • a simple restart - no luck - shutting down, unplugging everything (1 min, 5 mins, and overnight) just plugging in the DP cable and booting up - no luck
  • I reinstalled monitor drivers - no luck
  • I have a second monitor - when that is plugged into HDMI and my main monitor is DP - the main monitor can't be detected using windows or nvidia control panel. its like its not even plugged in
I'm at my wits end. I really want to use the DP as I have a 144hz monitor and HDMI only goes to 60hz. The DP cable was working when I first put the card in so I'm baffled as to why it suddenly wont work after the drivers were installed.
my specs;
BenQ XL2430T
i7-4790K 4.00Ghz
Gigabyte Z97X-UD5H-BK
16GB RAM Win 10
Asus 'Tuf Gaming' Geforce RTX 3070
750W Corsair PSU

Any suggestions would be fantastic
Thanks!
 
Dec 4, 2020
2
0
10
0
just got a new cable, turns out that was the problem! So frustrating considering the cable was perfectly fine before changing over the GPU!
 

ASK THE COMMUNITY

TRENDING THREADS