Question DisplayPorts no longer working

TheFishGuru

Reputable
Jul 25, 2016
1
0
4,510
0
Hello. So I tried to set up my Oculus Rift S using DisplayPort and I had no luck. So I tried using the DP that my second monitor was using and again, no luck. The problem I'm having now is that both the DPs that previously worked are not showing any signal to any of my monitors. The thing that really bugs me is that when I plug or remove the cable from the graphic card, both my monitors respond by turning on, only to display "no signal".

Surely, if my displayports were completely ruined my monitors wouldn't even detect any connection, I have all the latest drivers, including the ones for Displayport 1.3 and 1.4. I don't think it's the cables or the monitors because they all work when I use my third and final working DisplayPort (graphics card has three)

If anyone has a solution, I am willing to try anything at this point

Thanks in advanced
 

Ramael

Commendable
Sep 25, 2016
6
0
1,510
0
Hi, I did this to get my DP wokring again:
  • Using HDMI to get into BIOS and disable Fast boot
  • Using HDMI to get into Windows (Safe Mode) and uninstall the Nvidia drivers using DDU
  • Turned off FreeSync and DDC/CI on my monitor
  • Disconnect the HDMI and use only DP
At this point it still didn't work, even after restart, but then:
  • Reset the my motherboards (MSI) CMOS by pressing the reset CMOS button on the back of my monitor
  • Booted up my computer again and I had signal again and image on my monitor using DP.
Hope it helps!
 

ASK THE COMMUNITY