Question Distorted colors on startup(new build)

May 23, 2019
29
1
35
0
I built a pc 3 weeks ago and it started acting weird. i had some problems installing the gpu to case and mobo, but its been working fine for weeks so i didnt think there was any problem. but now i started having issues. it doesnt happen all the time. i can play games for hours and no problem, but when i boot the pc, 2 out of 5 times i see this:

https://ibb.co/1G27szm

distorted colors and everything. i can use the pc but it looks like this. it goes away after i reset the pc for a couplenof times. sometimes its not purple, its red, pink etc. and the last time it happened, it happened after a freeze. pc froze for like a minute and i couldnt even move the mouse so i had to restart, on the login screen, i saw the colors again.

i hope someone can find out what the problem is. i hope its not an hardware issue since its a new build. ive been been using the gpu for 2 years its from my old build and its been running fine, it runs idle most of the time so i dont think it got old. as i said, i play games for hours with no problem, but this color thing happens on some startups and it froze today.

thanks in advance.
 
May 23, 2019
29
1
35
0
Full aystem specs?

What type of cable are you using between your monitor and gpu? Vga? Dvi? Hdmi?

I would try reseating your gpu. Also i would reconnect both ends of your monitor cable.
i use Hdmi.Components are:
asrock b450m hdv
ryzen 2600
gigabyte rx460 4gb
2x8gb patriot 3000mhz ram

today i tried to reinstall gpu drivers. i uninstalled them in control panel and installed again, and screen turned green while installing. after that, i restarted the pc and i realized that monitor shows a weird screen just like old tvs do when there is no signal for a second(static, noise whatever you say), and a whole green screen for another split second before i can see the desktop. it happens almost everytime i restart the monitor. i dont know what all this mean and im frustrated, its a new pc its not meant to be that problematic. here are the pics of green screen during installation. it didnt go away until i restart the pc.

https://ibb.co/QJ0fKG2
https://ibb.co/zRZ9D9Y
 

ASK THE COMMUNITY

TRENDING THREADS