Question D'Link 2640 Smart AC2600

Aug 19, 2019
3
0
10
0
Hello,

I have a D'Link DIR-2640 wifi router, connected to a Hitron CGNM-2250 modem from my ISP (cable internet). The modem is in bridge mode. I have 10-14 clients at a time on my wifi (Google Home mini, Chromecasts, Nest thermostat and cameras etc), and my PS4 wired in. Typically only one device would be streaming at a time.

My wifi connection goes really well then just randomly drops devices momentarily, or sometimes longer, even if they are in position for great signal, its happened to cameras, Chromecasts and my Google Pixel 2. I did a factory reset last night of the router and today still having problems. At 12:36 my cameras both went off line so I pulled the router log. I was not home at the time but my wife was and she wouldn't be doing anything with the wifi settings.

One line in the log keeps repeating constantly all day

2019-08-19 12:35:54 syslog: dnssd_clientstub ConnectToServer: connect() failed path:/var/run/mdnsd Socket:27 Err:-1 Errno:0 Success

I have included a snapshot of the log at 12:36 where something else also happened in the log.

2019-08-19 12:36:00 syslog: dnssd_clientstub ConnectToServer: connect() failed path:/var/run/mdnsd Socket:27 Err:-1 Errno:0 Success
2019-08-19 12:36:00 syslog: dnssd_clientstub DNSServiceRefDeallocate called with NULL DNSServiceRef
2019-08-19 12:36:03 syslog: dnssd_clientstub ConnectToServer: connect()-> No of tries: 1
2019-08-19 12:36:04 [RC]: Wan(eth3) connect Success , Current Wan ip is 70.XXXXXX edit for rules
2019-08-19 12:36:04 miniupnpd[4763]: shutting down MiniUPnPd
2019-08-19 12:36:04 syslog: it is advised to use network interface name instead of 192.168.0.1
2019-08-19 12:36:04 miniupnpd[2705]: HTTP listening on port 6352
2019-08-19 12:36:04 syslog: dnssd_clientstub ConnectToServer: connect()-> No of tries: 2
2019-08-19 12:36:05 syslog: dnssd_clientstub ConnectToServer: connect()-> No of tries: 3
2019-08-19 12:36:06 syslog: dnssd_clientstub ConnectToServer: connect() failed path:/var/run/mdnsd Socket:27 Err:-1 Errno:0 Success
2019-08-19 12:36:06 syslog: dnssd_clientstub DNSServiceRefDeallocate called with NULL DNSServiceRef
2019-08-19 12:36:08 ipsec_setup: ...Openswan IPsec stopped
2019-08-19 12:36:08 FOTA[3588]: fota_config.c, fota_init_config, 322:
2019-08-19 12:36:08 FOTA[3588]: CA certificate is not set, use default file: /etc_ro/cacert.pem.
2019-08-19 12:36:08 FOTA[3588]: fota_config.c, fota_init_config, 335:
2019-08-19 12:36:08 FOTA[3588]: firmware encryption flag is on.
2019-08-19 12:36:08 FOTA_CONFIG[3592]: mtk/fota_generate_config.c, main, 1059:
2019-08-19 12:36:08 FOTA_CONFIG[3592]: Execute config ACTION: config.
2019-08-19 12:36:08 FOTA_CONFIG[3592]: mtk/fota_generate_config.c, action_config, 778:
2019-08-19 12:36:08 FOTA_CONFIG[3592]: Now start generating the configuration file.
2019-08-19 12:36:08 FOTA_CONFIG[3592]: mtk/fota_generate_config.c, main, 1067:
2019-08-19 12:36:08 FOTA_CONFIG[3592]: Done.
2019-08-19 12:36:08 FOTA[3588]: fota.c, main, 1348:
2019-08-19 12:36:08 FOTA[3588]: Execute ACTION: query.
2019-08-19 12:36:08 FOTA[3588]: fota.c, query_latest_firmware_info, 83:
2019-08-19 12:36:08 FOTA[3588]: Now check with the server for the latest firmware information.
2019-08-19 12:36:08 FOTA[3588]: fota_api_curl.c, get_http_response_code, 167:
2019-08-19 12:36:08 FOTA[3588]: iHttp_code=401.
2019-08-19 12:36:08 FOTA[3588]: fota.c, query_latest_firmware_info, 106:
2019-08-19 12:36:08 FOTA[3588]: Http code: 401, Error code: 111, error message: Invalid access token..
2019-08-19 12:36:08 FOTA[3588]: fota_api.c, refresh_access_token, 214:
2019-08-19 12:36:08 FOTA[3588]: Now REFRESH the access token.
2019-08-19 12:36:08 FOTA[3588]: fota_api_curl.c, get_http_response_code, 167:
2019-08-19 12:36:08 FOTA[3588]: iHttp_code=200.
2019-08-19 12:36:08 FOTA[3588]: fota_api.c, refresh_access_token, 248:
2019-08-19 12:36:08 FOTA[3588]: REFRESH the access token success.
2019-08-19 12:36:08 FOTA[3588]: fota.c, query_latest_firmware_info, 83:
2019-08-19 12:36:08 FOTA[3588]: Now check with the server for the latest firmware information.
2019-08-19 12:36:09 FOTA[3588]: fota_api_curl.c, get_http_response_code, 167:
2019-08-19 12:36:09 FOTA[3588]: iHttp_code=200.
2019-08-19 12:36:09 FOTA[3588]: fota.c, query_latest_firmware_info, 116:
2019-08-19 12:36:09 FOTA[3588]: QUERY the latest firmware information success.
2019-08-19 12:36:09 FOTA[3588]: fota.c, select_firmware_version, 442:
2019-08-19 12:36:09 FOTA[3588]: Now CHOOSE a viable firmware version.
2019-08-19 12:36:09 FOTA[3588]: fota.c, check_enforced_version, 411:
2019-08-19 12:36:09 FOTA[3588]: Now check enforced version.
2019-08-19 12:36:09 FOTA[3588]: fota.c, check_enforced_version, 425:
2019-08-19 12:36:09 FOTA[3588]: 'pEnforced_exist' is null pointer.
2019-08-19 12:36:09 FOTA[3588]: fota.c, select_firmware_version, 488:
2019-08-19 12:36:09 FOTA[3588]: Select upgrade stable firmware.
2019-08-19 12:36:09 FOTA[3588]: fota.c, select_firmware_version, 502:
2019-08-19 12:36:09 FOTA[3588]: No newer firmware is available.
2019-08-19 12:36:09 FOTA[3588]: fota.c, main, 1401:
2019-08-19 12:36:09 FOTA[3588]: The value of 'iRet' is not OK.
2019-08-19 12:36:09 syslog: fota_common.c, fota_unlock, 331:
2019-08-19 12:36:09 syslog: fota lock is uninitialized, no need to unlock.
2019-08-19 12:36:10 syslog: dnssd_clientstub ConnectToServer: connect()-> No of tries: 1
2019-08-19 12:36:11 syslog: dnssd_clientstub ConnectToServer: connect()-> No of tries: 2
2019-08-19 12:36:12 syslog: dnssd_clientstub ConnectToServer: connect()-> No of tries: 3
2019-08-19 12:36:13 syslog: dnssd_clientstub ConnectToServer: connect() failed path:/var/run/mdnsd Socket:27 Err:-1 Errno:0 Success
2019-08-19 12:36:13 syslog: dnssd_clientstub DNSServiceRefDeallocate called with NULL DNSServiceRef
2019-08-19 12:36:16 syslog: dnssd_clientstub ConnectToServer: connect()-> No of tries: 1
2019-08-19 12:36:17 syslog: dnssd_clientstub ConnectToServer: connect()-> No of tries: 2
2019-08-19 12:36:18 syslog: dnssd_clientstub ConnectToServer: connect()-> No of tries: 3

What is causing me these problems? Is it my router, modem, a client? Firewall settings are DMZ disable, and SPI IPv4, anti-spoof checking, IPv6 Simple Security and IPv6 ingress filtering enabled.
 
Aug 19, 2019
3
0
10
0
I rebooted it. The logs show before and after reboot this block repeated over and over several times a minute every minute.


2019-08-20 00:14:23 syslog: dnssd_clientstub DNSServiceRefDeallocate called with NULL DNSServiceRef
2019-08-20 00:14:26 syslog: dnssd_clientstub ConnectToServer: connect()-> No of tries: 1
2019-08-20 00:14:27 syslog: dnssd_clientstub ConnectToServer: connect()-> No of tries: 2
2019-08-20 00:14:28 syslog: dnssd_clientstub ConnectToServer: connect()-> No of tries: 3
2019-08-20 00:14:29 syslog: dnssd_clientstub ConnectToServer: connect() failed path:/var/run/mdnsd Socket:27 Err:-1 Errno:0 Success

I did a manual check for firmware updates and found none. The logs also showed this and that there was no newer firmware.
 

ASK THE COMMUNITY

TRENDING THREADS