Question Do I have a faulty USB HDD enclosure ?

knowledge2121

Honorable
Sep 5, 2013
407
1
10,795
2
I copy some big files from my computer to my USB enclosure and leave my computer and go downstairs ... after I come back the drive is frozen and I have to unplug/replug it to make it work again..

My guess is that the enclosure is put to sleep by Windows when it finishes the file transfers and does not wake itself up....this is my enclosure..

I compare the files after unplugging/re-pluging the device, and their size is identical on both my computer and the USB HDD...which means the transfers are completed successfully....and it is put to sleep after the file transfers are done....right ?

Is there a way to change a settings in Windows10 so that the USB enclosure is not put to sleep ?

Which enclosure do you recommend that does not suffer from this defect ?
 
Last edited:

robert600

Distinguished
Jan 19, 2012
1,009
8
19,665
141
The link you provide goes to a list of orico enclosures so ... I'm not sure what one you have. I use orico enclosures myself and have never had that problem.

You could try this:

open device manager
expand the Universal Serial Bus controllers branch
right-click the USB Root Hub
select properties
click the 'power management' tab
uncheck the box that says 'allow the computer to turn off this device to save power'

that should do it ... I have to admit I've never used this setting but it sounds like what you want.
 

knowledge2121

Honorable
Sep 5, 2013
407
1
10,795
2
I updated the link, I tried many things to solve the issue....but it persists...I tried what you said as well...with no luck...I have two enclosures and both of them behave similarly...I also have a Seagate external HDD which does not have this issue...
 

robert600

Distinguished
Jan 19, 2012
1,009
8
19,665
141
Oh ... I thought that would work.

I have pretty much the same enclosure except mine is transparent ... I use Win10 ... I've put a few different HDs in it and have had no issues.

The two enclosures you have ... do they have identical HDs in them?
Do you have access to another computer where you could try them to see if they freeze in that system?
 

knowledge2121

Honorable
Sep 5, 2013
407
1
10,795
2
I plugged in my Seagate USB HDD and it doesn't have this problem....it is definitely the enclosure or maybe the hard disk in it...maybe i should update the HDDs firmware ? hmmm
 

knowledge2121

Honorable
Sep 5, 2013
407
1
10,795
2
wait a minute though....do identical enclosures cause trouble ? I had two identical enclosures with different HDDs in them connected to USB ports....would that cause any issues ?
 

ASK THE COMMUNITY

TRENDING THREADS