Jmunk

Honorable
Apr 18, 2015
91
0
10,630
0
So the rig is a i9-9900k, 2080 SUPER, and 32 GB of RAM.

This is my streaming and gaming build, primarily playing Warzone on stream. I've had to dedicate my old PC as an dedicated stream PC using NDI scan convertor just because I really didn't feel like I was getting the performance out of my hardware that I felt I should. Maybe you guys can tell me if something looks off, or maybe I'm just expecting too much?

I have everything, including textures, either the lowest or off in WZ. There are at times (depending on the location) where I'm getting 120-130 FPS. The average is right around 150, with highs in the 170/180 when looking into the forest or the edge of the map. That's without OBS opened, let alone streaming. When I stream (I use the NVEC encoder, since using x264 nets me around 30-40 less FPS), I get an average of maybe around 130-140 FPS. Am I crazy for thinking this is way underperforming for this rig? I know WZ isn't the most well-optimized game, but I feel like something isn't quite right with my setup here and I can't figure out what it is.
 

Jmunk

Honorable
Apr 18, 2015
91
0
10,630
0
Lilkely just gpu that is at it's max's performance.
Think so? When I stream with the NVEC encoder and play, in the task manager the GPU is sitting around 95%, sometimes 97 percent. Oddly enough it says 0% utilization for Modern Warfare, but I think that's just a task manager bug.

So maybe I am just being too idealist with my expectations. I wonder, though, why my CPU is maxing out so easily too. I can't stream, even if I wanted to, at the "very fast" preset using x264 without encoding lag and frames in game dropping 30 FPS or more. So my GPU and my CPU are just maxing out streaming Modern Warfare at the lowest settings possible? It just all seems odd to me.

Here's my latest user benchmark in case anyone is wondering: https://www.userbenchmark.com/UserRun/37460967
 
Last edited:

Vic 40

Titan
Ambassador
Here's my latest user benchmark in case anyone is wondering: https://www.userbenchmark.com/UserRun/37460967
One thing i can make out of this is that you run an old bios so maybe that updating wil help.

Looking at the performance does your pc seem to do fine so see not if anything is holding it back which means that you are possibly doing the max it can where i think that the gpu is likely the one that is really maxing out.
 

ASK THE COMMUNITY