Question Dram light continuously lit

Aug 2, 2019
1
0
10
0
Hello, I am a first time builder. I have G.Skill Ripjaws V series ram (model number: F4-3200C16D-32GVK) and am using it with a Asus ROG Strix X470-F gaming motherboard. When I initially built the unit it booted seamlessly, however, upon entering my BIOS, I saw that I only had on stick of ram working as I only had 16gb available (my setup is 32 gb total and has 2 16gb sticks). I decided to go ahead and continue using the system as it was because I was going to need to open it back up at the end of the week to install another hard drive that was coming in the mail. Well, here we are at the end of the week. When I tried moving the ram around, my system failed to post and is stuck in power standby mode with the dram light continuously lit. There was no beeping nor were there any flashing LEDs. I have tried both sticks of ram individually in each of the 4 sockets as well as various combinations of the two. I would suspect the RAM was DOA, but, as I mentioned before, at least one stick initially worked. I have now placed everything back as it initially was when it was working, but I am still having the same issue. Any help is greatly appreciated.
 

WaltzWorker

Reputable
Mar 18, 2015
156
15
4,715
22
It's probable that the RAM came virtually DOA - and you got some use out of one before it died... There is the possibility that the MB is bad and caused that first working RAM to fail once you moved it... Another possibility is that its the MB is bad and you pulled the bad one and got some use out of the good ram before you moved it to the bad slot(s). I hope you turned off the system and let it sit for a few minutes before doing anything inside. I would also look down into the RAM slots to make sure nothing fell into it...
One thing to do now is to go back in (after turning off the system and unplugging it and letting it sit for at least a few minutes) and then make sure all connections and components are secured and in place. Then try again.
 

ASK THE COMMUNITY

TRENDING THREADS