Question dram lights up for ~5 seconds, turns off then vga and boot turn on during startups. Should I worry?

Nov 18, 2022
1
0
10
0
Hello,

I just finished building and kept getting a CPU + dram led until I realized I hadn’t plugged in the CPU power. (I know I'm dumb)
Once plugged in the CPU light stopped coming up, however, the dram still lit up for ~10 secs before turning off and continuing with the VGA light and then the boot light.
I managed to get into the BIOS, installed windows and everything seems working alright. Nothing seems out of the ordinary.

Now every time I start up my PC I get the same ~5 seconds dram, VGA and boot turn on during startups. The thing I'm worried about is the dram light coming on, I'm pretty sure the vga + boot is normal.
Is this a normal thing? Did I do something wrong?

Here are my specs: https://pcpartpicker.com/list/NXXtqm
I currently have a 1050 ti in the system, will be upgrading soon.

Thanks!
 

Aeacus

Champion
Ambassador
All the qLED lights coming on for a second and then going away once PC POSTs, is normal.

Same is with cars as well. E.g if you were to start the engine, all the warning lights will lit up as soon as you crank the starter but once engine starts running, they all go away (if given car doesn't have an issue).

Did I do something wrong?
You already confirmed it:
until I realized I hadn’t plugged in the CPU power. (I know I'm dumb)
Has that any adverse effect? Well, if PC POSTs and boots to OS, i'd say you got lucky and all is fine.
 

ASK THE COMMUNITY