Question dramaticly reduced speed with tplink mesh m5

Jan 26, 2023
3
0
10
0
Hi, been looking at this for a while now.
i change to fiber internet. with a speed of 300mb (dl/ul)
i was provided with a router for high speed by halny (https://halny.com/)

i have 2 floors at my house and 3 mesh m5 devices.
the 1st is the master connected via cable to the halny router. when i conncet my phone to that mesh device i get about 160-180 DL dpeed.
at the second one on the other side of the house i get around 30-60
on the second floor i get aroung 15-35.

with my old provider (diffrent modem - for dsl connection) i had same speed (give or take) around the house. whats going on?
i have tried to set the QOS of the mesh m5 to 300 manualy for both upload/download. that didnt fix anything. checking with my ISP : they said that if connecting directly the router i get about 160-180 tha is ok the rest is nothing the can help with.
could turning off the WIFI of the router it self help? (since the wifi network would come from the mesh anyway)

thanks for any advice.
 

JohnMGotts

Commendable
Dec 7, 2020
86
7
1,545
4
Can you verify your speeds with an ethernet connected PC at the router?
(Just as a baseline for actual speeds) I don’t understand the 300/300 and 160-180 DL as being acceptable. If you pay for 300/300 you should get it with a hardwired device.
 
Last edited:
If you get 300mbps connected via ethernet then it is likely working correctly. It is not uncommon to get the speeds you do. It could be your end device that is limiting you. You might if you were lucky get 300mbps sitting closer to the router.

You have made it even more complex by adding a mesh system. This just adds more wifi radios all competing for the same bandwidth. It is extremely common to lose well over half the speed when you use repeater/mesh systems.
 

JohnMGotts

Commendable
Dec 7, 2020
86
7
1,545
4
The critical link is the master mesh tethered to your router/modem, the bandwidth you’re using (I’m assuming 5ghz vs 2.4.) The 5 will give you faster speeds, 2.4 longer distance at slower speeds. I assume the phone or tablet you’re using is capable of comms at 200 (which is likely.) The placement of the master is key to comms to the others, so I would propose relocating it closer to the other units if possible, thus balancing the bandwidth better between locations. Internet access speed is what you’re paying for so it’s not the issue. Better mesh system might help but…
 
Last edited:

ajohnson30

Distinguished
Jul 26, 2012
28
3
18,545
1
<snip>
could turning off the WIFI of the router it self help? (since the wifi network would come from the mesh anyway)
Yes, definitely. You don't want multiple wifi signal sources when you're trying to do mesh. That's like trying to watch a show on TV when there's another TV right next to it playing a different program.

Disable the router's wifi, turn off ALL the units, then turn on the master unit, wait until it's up, then turn on the satellites one at a time, waiting until they come up, and see how they do.

If at all possible, I'd recommend a wired connection between the satellite units and the master, but I assume that's not possible/practical.
 

JohnMGotts

Commendable
Dec 7, 2020
86
7
1,545
4
Shouldn’t make a difference, it’s just “listening.”
BTW, what wifi speeds do you get with the router standalone? 2.4 & 5 bands standing close.
 

JohnMGotts

Commendable
Dec 7, 2020
86
7
1,545
4
OK, so that’s the max you can expect on wireless regardless and is comparable to what you saw on the mesh master location. For the distant satellites in your config., I would access them up on the 2.4 band. The router you were provided should be able to get 300mbs on wireless depending on your phone/tablet/pc capabilities. If it doesn’t, I would look for a better router/modem or check with the provider for the specs on the one provided.
I use a Spectrum router/modem and with my Iphone XS and version 9 Ipad get 280-320 at 5ghz, 100 at 2.4 on wireless at the unit on a 300mbs subscription. You’re either limited by the capabilities of your access devices or the wireless side of the router itself is not cutting it.
 

ASK THE COMMUNITY