[SOLVED] Driver Power State Failure BSOD upon cold boot ?

Oct 27, 2022
  • OS - Windows 11
  • x64 (64-bit OS)
  • Originally windows 10 was installed. I later upgraded to windows 11.
  • The problem I am encountering already occured in windows 10.
  • Full retail version. I installed Windows 10 myself.
  • Build this desktop back in October 2019
  • Upgraded to windows 11 a couple of months ago. I opted for the full fresh install.
  • AMD 3700X
  • Gigabyte RTX 2070 super
  • ASRock X570 Steel Legend
  • Corsair RM750X
  • System Manufacturer: ME
  • Desktop
Hi everyone,

Everytime I cold boot my PC I run into a Driver Power State Failure BSOD. Interestingly, if I restart my PC before the BSOD occurs, I prevent the BSOD. Basically, after restart (or forced restart by the BSOD) the PC runs perfectly fine. Hope someone can help me with identifying the problem!

As mentioned in the posting instructions I have run the Sysnative BSOD Dump and generated a report using Performance Monitor. You can find them here: https://drive.google.com/drive/folders/1w_xhMI8pik-svi-eSiN3btbSccrWA3uD?usp=sharing

Many thanks for the help!


Win 11 Master
latest motherboard bios?
close, there is a beta version since the one they on. Oddly beta 4 months old and hasn't exited beta state

wonder if its Nvidia drivers

Report - Click run as fiddle to read

File: 102722-8062-01.dmp (Oct 27 2022 - 17:58:40)
*** WARNING: Unable to verify timestamp for nvvhci.sys
Probably caused by: nvvhci.sys (Process: System)
Uptime: 0 Day(s), 1 Hour(s), 49 Min(s), and 16 Sec(s)

File: 102622-8140-01.dmp (Oct 26 2022 - 17:15:15)
*** WARNING: Unable to verify timestamp for nvvhci.sys
Probably caused by: nvvhci.sys (Process: System)
Uptime: 0 Day(s), 10 Hour(s), 07 Min(s), and 19 Sec(s)

File: 102422-8156-01.dmp (Oct 25 2022 - 07:06:23)
Probably caused by: xusb22.sys (Process: System)
Uptime: 0 Day(s), 0 Hour(s), 41 Min(s), and 58 Sec(s)

File: 101422-8718-01.dmp (Oct 15 2022 - 02:53:43)
Probably caused by: xusb22.sys (Process: System)
Uptime: 1 Day(s), 0 Hour(s), 40 Min(s), and 43 Sec(s)

File: 101022-9703-01.dmp (Oct 11 2022 - 03:41:16)
Probably caused by: xusb22.sys (Process: svchost.exe)
Uptime: 3 Day(s), 20 Hour(s), 39 Min(s), and 09 Sec(s)

top 2 blame
Jan 11 2020nvvhci.sysNvidia Virtual USB Host Controller driver http://www.nvidia.com/
So I would run DDU in safe mode, uninstall Nvidia drivers, log back into normal mode and reinstall Nvidia drivers

Bottom 3 mention xusb22.sys which is the Xbox 360 Common Controller for Windows. Which is odd as WIndows drivers don't cause BSOD... not without assistance.

Try updating chipset drivers, don't need StoreMi or RAID - https://www.amd.com/en/support/chipsets/amd-socket-am4/x570

if you looking for a driver that won't like fast startup, its likely your wifi adapter
Feb 06 2014bcmwl63a.sysBroadcom 802 11 Network Adapter Wireless driver http://www.broadcom.com/support/
given its age, I can just guess it isn't a win 10 driver.

It could be what is setting off the 2 other USB drivers.

Fast startup in windows should be off though so it should have only been a problem in 10.
To confirm its off in 11, search for control panel
set view to large icons
choose power options
click Choose what the power button does
By default, Turn on fast Startup should be off.

If its ticked, click Change settings the are currently unavailable
untick Turn on fast startup.

Note: Fast Boot in Bios isn't same thing as Fast Startup in windows.
Last edited:


Jul 29, 2016
It's the NVIDIA Shield streaming device that's causing the BSODs. In the Analyze -v output argument 4 is the blocked IRP address...
Rich (BB code):
A driver has failed to complete a power IRP within a specific time.
Arg1: 0000000000000003, A device object has been blocking an IRP for too long a time
Arg2: ffff8b0131e4bca0, Physical Device Object of the stack
Arg3: ffffdc0e8a325818, nt!TRIAGE_9F_POWER on Win7 and higher, otherwise the Functional Device Object of the stack
Arg4: ffff8b0134197010, The blocked IRP

Displaying the IRP (in an example dump, the others are similar) gives...
Rich (BB code):
12: kd> !irp ffff8b0134197010
Irp is active with 3 stacks 2 is current (= 0xffff8b0134197128)
No Mdl: No System Buffer: Thread 00000000:  Irp stack trace. 
     cmd  flg cl Device   File     Completion-Context
            0  0 ffff8b0131e4bca0 00000000 00000000-00000000   
            Args: 00000000 00000000 00000000 00000002
            0 e1 ffff8b0132506de0 00000000 fffff804523a5a80-ffff8b0125f6b160 Success Error Cancel pending
           \Driver\xusb22    nt!PopRequestCompletion
            Args: 00051100 00000001 00000001 00000002
[N/A(0), N/A(0)]
            0  0 00000000 00000000 00000000-ffff8b0125f6b160   

            Args: 00000000 00000000 00000000 00000000

The driver blocking the IRP is \Driver\nvvhci.sys. The address of the device object is provided in that output (0xffff8b0131e4bca0) and displaying that device object gives...
Rich (BB code):
12: kd> !devobj ffff8b0131e4bca0
Device object (ffff8b0131e4bca0) is for:
Cannot read info offset from nt!ObpInfoMaskToOffset
\Driver\nvvhci DriverObject ffff8b012af96b60
Current Irp 00000000 RefCount 3 Type 0000002a Flags 00003050
SecurityDescriptor ffffbf8cbc6e5ce0 DevExt ffff8b0131e4bdf0 DevObjExt ffff8b0131e4bf28 DevNode ffff8b012f057c30 
ExtensionFlags (0000000000) 
AttachedDevice (Upper) ffff8b0132506de0 \Driver\xusb22
Device queue is not busy.

In the device object we can see the address of the device node (0xffff8b012f057c30) and displaying that gives...
Rich (BB code):
12: kd> !devnode ffff8b012f057c30
DevNode 0xffff8b012f057c30 for PDO 0xffff8b0131e4bca0
  Parent 0xffff8b0124369a60   Sibling 0000000000   Child 0xffff8b012f5879a0  
  InstancePath is "USB\Vid_0955&Pid_b400\1&1651c353&0&01"
  ServiceName is "xusb22"
  State = DeviceNodeStarted (0x30a) @ 2022 Oct 25 20:08:19.148
  Previous State = DeviceNodeEnumerateCompletion (0x30f) @ 2022 Oct 25 20:08:19.148
  StateHistory[12] = DeviceNodeEnumerateCompletion (0x30f)
  StateHistory[11] = DeviceNodeEnumeratePending (0x30e)
  StateHistory[10] = DeviceNodeStarted (0x30a)
  StateHistory[09] = DeviceNodeEnumerateCompletion (0x30f)
  StateHistory[08] = DeviceNodeEnumeratePending (0x30e)
  StateHistory[07] = DeviceNodeStarted (0x30a)
  StateHistory[06] = DeviceNodeStartPostWork (0x309)
  StateHistory[05] = DeviceNodeStartCompletion (0x308)
  StateHistory[04] = DeviceNodeStartPending (0x307)
  StateHistory[03] = DeviceNodeResourcesAssigned (0x306)
  StateHistory[02] = DeviceNodeDriversAdded (0x305)
  StateHistory[01] = DeviceNodeInitialized (0x304)
  StateHistory[00] = DeviceNodeUninitialized (0x301)
  StateHistory[19] = Unknown State (0x0)
  StateHistory[18] = Unknown State (0x0)
  StateHistory[17] = Unknown State (0x0)
  StateHistory[16] = Unknown State (0x0)
  StateHistory[15] = Unknown State (0x0)
  StateHistory[14] = Unknown State (0x0)
  StateHistory[13] = Unknown State (0x0)
  Flags (0x6c000130)  DNF_ENUMERATED, DNF_IDS_QUERIED,
  CapabilityFlags (0x00000a11)  DeviceD1, Removable,
                                SurpriseRemovalOK, WakeFromD1

Here we see the VID and PID of the actual device (Vid_0955&Pid_b400). If you look that up (https://devicehunt.com/view/type/usb/vendor/0955/device/B400) it's for the NVIDIA Shield device.

The driver that's identified in the device object (\Driver\nvvhci) is over two years old...
Rich (BB code):
12: kd> lmDvmnvvhci
Browse full module list
start             end                 module name
fffff804`74d90000 fffff804`74da0000   nvvhci   T (no symbols)          
    Loaded symbol image file: nvvhci.sys
    Image path: nvvhci.sys
    Image name: nvvhci.sys
    Browse all global symbols  functions  data
    Timestamp:        Fri Jan 10 20:31:07 2020 (5E18C2EB)
    CheckSum:         00019C8C
    ImageSize:        00010000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
    Information from resource tables:

I would suggest that you look for an update to the NVIDIA Shield drivers here. Alternatively open a support ticket with NVIDIA.