Drivers don't want to install on my surface pro?

sweatyturtle

Honorable
Jul 27, 2013
1
0
10,510
0
Ok so this is what happened:
1) Bought a USB2.0 to Ethernet adapter which uses the ASIX AX88772 driver.
2) Installed drivers successfully onto my surface pro, confirmed because I checked in device manager
3) Plugged in the hardware, and everything was functioning normally.
4)Went to go test it out buy unplugging the Ethernet cable that goes from my modem to my router
5) So the setup was modem-->Ethernet--->Adapter
6)Went to Network and Sharing Center
7)Tried to see why the internet wasn't working
8)After this, an error message came up telling me that "a network cable is either unplugged or broken"
9) After this I disabled the driver, in hopes of re-enabling it again but after I disabled it, it just disappeared.

Now after trying to reinstall the drivers again, and doing a full RESTORE OF WINDOWS, I still can't install the drivers, I run the setup program I was given by the manufacturer and it just won't appear in device manager, even with show hidden devices checked.

I am going to University in the fall and my only means of getting internet is through a Ethernet port, which the surface doesn't have. And I have lost hope almost for this adapter. If I were to purchase the official Microsoft Surface Pro USB to Ethernet adapter, would I have the same problem.

OR Should I just buy a router, but if I were to buy one, I'm not so sure how to install it with just an Ethernet cable sticking out of the wall.

Thanks in advance
 

ASK THE COMMUNITY

TRENDING THREADS