babusca

Distinguished
Apr 15, 2011
13
0
18,510
So, the other day I uninstalled my ati display drivers, planning on reinstalling them because they were acting up. I restarted my computer, and I'm now using the "Standard VGA Graphics Adapter" (according to device manager). I've tried reinstalling the ati display drivers from the website, but for some reason, it just doesn't work? I don't think my computer recognizes that I have a video card -.-. Any solutions? Not having drivers makes me unable to play any games on steam, they launch, and then close right away. Portal 2 will be out any day now, I already pre-ordered it. I'll be really angry if I'm not playing because of stupid drivers. I've tried several solutions, but to no prevail :'(

I'm using Windows 7 Home Premium 64-Bit, graphics card is Ati Radeon HD 6570, if you need more info, ask.




EDIT: After installing display drivers from the ati website, they don't show up in device manager, and the screen does not change, leading me to believe it doesn't recognize my video card or something.
 

leon2006

Distinguished
Try this

Install/Un-install procedure for CCC @ command prompt environment:

Un-install ATI driver

Log in as administrator

@ Command prompt execute the following instructions

Go to C:\ATI\SUPPORT\9-REV_vista64_win7_dd_ccc_wdm_emu\Driver\BIN64 for 64 bit OS
Go to C:\ATI\SUPPORT\9-REV_vista32_ win7_dd_ccc_wdm_emu\ Driver\BIN for 32 bit OS

Type the command “atisetup.exe –uninstall”

This will remove the current or older ATI driver on your PC. Wait for the process to complete.

The Font will get big as the OS will revert to default VGA driver. This is expected or normal just as when installing windows for the 1st time.

Reboot your machine after the completion of the process
Install ATI driver
Log in as administrator

@ Command prompt execute the following instructions

Go to C:\ATI\SUPPORT\9-REV_vista64_win7_dd_ccc_wdm_emu\ Driver\BIN64 for 64 bit OS
Go to C:\ATI\SUPPORT\9-REV_vista32_ win7_dd_ccc_wdm_emu\ Driver\BIN for 32 bit OS

Type the command “atisetup.exe –install – output screen”

This will install the ATI driver on your PC. You will see DOTS on the command prompt terminal. Wait for the process to complete.

When done the ATI CCC installation log will come-up to detail the installation summary.

Reboot your machine

Configure your graphic settings when you log in.


Notes:

1) @ command prompt type ”ATIsetup.exe -?” it will give you the list options for the ATIsetup.exe installation program

2) 9-Rev is whatever revision of ATI driver you are using (i.e. 9-10).

3) Always un-install old driver before installing the new rev driver

 

jockey

Distinguished
Feb 28, 2010
746
0
19,060
I just go to AMD.com/gaming, or AMD.com and select gaming, downloads. The latest driver versions will be there. Select OS, download, then open file for install. As long as your display is plugged into your card, it should be recognized. CCC will open after install.
Also, see that Init display device is selected to PEG in the bios.
 

babusca

Distinguished
Apr 15, 2011
13
0
18,510
@leon2006


Thanks for the quick reply! I'm trying this right now, i'll get back to you in a bit.



@jockey

Did you even read my post? I've already tried reinstalling new drivers -_-





 

jockey

Distinguished
Feb 28, 2010
746
0
19,060
Does your board have integrated graphics? I'd double check that primary display in the bios is set to PEG. Double check windows control panel settings also, something there may have defaulted to a wrong setting.
 

babusca

Distinguished
Apr 15, 2011
13
0
18,510
@leon2006

It did not work. I followed all the steps correctly, it installed, etc, I rebooted, but device manager still says im using default adapter, and my games still wont start up. Thanks anyways, though.


@jockey

I'm not using integrated graphics. I checked control panel, everything seems normal, and I do not know how to check my primary display in the bios.
 

leon2006

Distinguished
You need to go to bios and disable integrated graphics on your motherboard.

List the model and brand of your motherboard.

Can you list down your pc hardware details including power supply.

One common GPU driver failure to install is insufficient PSU. If the PSU can't power up the GPU it reverts to STANDARD VGA driver.
 

babusca

Distinguished
Apr 15, 2011
13
0
18,510
Bios primary display is set to PCI-E.

I used Belarc Advisor and this is some of the info i got:


System Model:

Hewlett-Packard p6741f
System Serial Number: MXX1070NJT
Asset Tag: MXX1070NJT
Enclosure Type: Desktop

Operating System:

Windows 7 Home Premium (x64) Service Pack 1 (build 7601)
Install Language: English (United States)
System Locale: English (Canada)



Main Circuit Board:

Board: FOXCONN 2A92 1.01
Bus Clock: 200 megahertz
BIOS: American Megatrends Inc. 6.09 09/07/2010


Processor:

3.20 gigahertz AMD Phenom II X4 955
512 kilobyte primary memory cache
2048 kilobyte secondary memory cache
6144 kilobyte tertiary memory cache
64-bit ready
Multi-core (4 total)
Not hyper-threaded


Memory Modules:

8184 Megabytes Usable Installed Memory

Slot 'DIMM1' has 2048 MB (serial number DB09160F)
Slot 'DIMM2' has 2048 MB (serial number D709B60F)
Slot 'DIMM3' has 2048 MB (serial number CE09B60F)
Slot 'DIMM4' has 2048 MB (serial number CF09260F)


Bus Adapters:

AMD AHCI Compatible RAID Controller
AMD RAID Console
Standard Enhanced PCI to USB Host Controller (2x)
Standard OpenHCD USB Host Controller (5x)



NOTE: under display, it says:

Standard VGA Graphics Adapter [Display adapter]
Acer AL1706 [Monitor] (17.1"vis, s/n L460C1484015, December 2006)





Also, I did not build this. I bought it new at futureshop, it's about 1 and a half months old. Here's the link:

http://www.futureshop.ca/en-CA/product/hewlett-packard-hp-pavilion-amd-phenom-ii-quad-core-955-desktop-p6741f-english-p6741f/10161108.aspx?path=2c3b4bf3500dbc87eb2c77370376a689en02


I do not know if this is accurate, but one of the reviews for the computer on futureshop said the power supply was 300 W.
 

leon2006

Distinguished
You may have a case of insufficient PSU from HP. This is an HP pc that use foxconn motherboard.

Calculate your load to guide you select the capacity you need.

http://www.antec.outervision.com/

Corsair, Seasonic, Antec are the good brand PSU
 

babusca

Distinguished
Apr 15, 2011
13
0
18,510
I looked at my power supply, doesn't say anything about watts, so I assume 300 W is correct.. I do not know how to check my motherboard, what I told you is simply what it said on Belarc. I filled in as much as I could on that calculator thing, says i need about 660 W.
 

leon2006

Distinguished



Get known good brand PSU.. Corsair, Seasonic, XFX, Antec.

If you want to try it out go to Best Buy or Frys... These stores have 30 return policy. You can return the PSU if it does not fix the problem.

You can also get PSU online like newegg.com
 

phaedrus2129

Distinguished
Apr 13, 2011
87
0
18,640
It isn't a power supply issue. The 6570 draws very little power, and if it wasn't receiving sufficient power the drivers would still have installed successfully.

A bad or insufficient PSU can cause many issues, but this is not one of them. Don't make the guy waste his own hard earned cash on something that won't fix his problem.
 

babusca

Distinguished
Apr 15, 2011
13
0
18,510
Just did a fresh install of Windows, everything seems normal, but I haven't been able to test the issue yet, but it DOES show the ati drivers in device manager :)
I'm not sure what made it unable to install before, as I had reinstalled it prior to that, and it worked fine. Thanks for your help, everyone.
 

ghinopley

Honorable
Jan 30, 2013
15
0
10,520
I have a similar problem being that i spent a whole ton of money on a 7950 gpu and the only way to make it worth the money is to get a driver from the internet which is unavalable thanks to my new earthnet card that also needs a driver from the internet!\

Any sujestions? :sol:
 

troutzed

Honorable
Jul 29, 2013
1
0
10,510
I am having the exact same problem with my 7950, all new hardware and i can get the card to work with the driver disc that came with it but the new drivers from ATI wont work. Dam i should have bought a nvidia, what a joke.