Question Drop in FPS after fitting 240 AIO (Red Dragon 5600XT Card) (SOLVED)

Nov 6, 2020
7
0
10
0
Hi everyone, I really hope someone can help. I have fitted a DeepMaxx 240 AIO replacing my BeQuiet Dark Rock 2 and I am now suffering a massive FPS drop in game.

I have checked temps (all okay at idle and in game), checked and re-applied thermal paste, done a re-install, checked GPU drivers, up to date and rolled back and absolutely nothing works. But I did find something.

So, PC works perfectly, games start up no problem and everything as it is normally but when I fly into a landing zone the FPS drops from a previously stable 110 to about 60 and as low as 40.

After trying everything I ran "benchmark". When I built the system six weeks ago it passed with flying colours and came out as an Aircraft Carrier. However, when I run it now I see two things.

As in the screen shots it cannot complete the test as in the GPU section it was unable to complete the third out of three tests which relate to 3D DX11.

It completes 3D DX9, then 3D DX10 but not the last 3D DX11 and I think this is the issue.

I believe this relates to Direct X.

Windows tell me it is working fine and I think this may be the problem.

Could anyone advise me on how to fix my issue? I would be so grateful.

See below a list of my parts.

Thanks,

Scotty

AMD Ryzen 3600 CPU
DeepCool Gammaxx L240 V2 RGB AIO
MSI B450 Gaming Pro Carbon Max WiFi ATX AM4 Motherboard
Corsair Vengeance Pro 16GB (2 X 8) DDR4-3200 CL16 Memory
Adata XPG SX6000 Pro 512 GB M.2 NVME Solid State Drive
PowerColor Radeon RX5600 XT 6GB Red Dragon Video Card
MSI Sekira 100R ARGB Gaming Case
Corsair TXM Gold 550W 80+ Gold Certified Semi Modular ATX Power Supply
 

Lutfij

Titan
Moderator
If you're serious about the first line, we might need to call in the authorities...just saying since things like that aren't to be taken lightly, not in 2021.

As for the rest of your thread, the thread title is misleading since it seemed to me like you slapped on an AIO onto the GPU and then met with the FPS drops. Anyways, if you replaced the CPU cooler alone and you're very confident that the mounting for the AIO cooler's plate is as flush as possible(inspecting the mount would be a good thing) then you need to look at other arenas of your build.

I'd see if you're on the latest BIOS version for your motherboard. If you have an number of BIOS version to pass before you reach the latest, gradually work your way to the latest, don't jump to the latest. Keep note of any chipset drivers that you might need to install before you move onto another BIOS version/update.

Then look into the version of your OS. We're currently on version 20H2. What game are you taxing the system with? You might then need to look into sourcing the latest drivers from AMD's support site. Use DDU to uninstall drivers, then manually install the drivers in an elevated command, i.e, Right click installer>Run as Administrator.

How old is that PSU?
 
Last edited:
Nov 6, 2020
7
0
10
0
The PSU is six weeks old and according to PC Part Picker is only drawing about 55% of its capacity.

Checked the mounting and all okay.

Went through BIOS to the latest.

The game I play is Destiny but experiencing it in other games like Warframe.

The games play fine, no noticeable temp spikes under load, all stable and just the massive drop in FPS.

And I went through all the drivers. The only thing I can think off but not convinced it would even work is to do a clean OS install.

Thanks,

Scotty.
 
Nov 6, 2020
7
0
10
0
Hi everyone, I thought I would post this in case it helps someone in the future. I fitted a new AIO ( do not know why it caused this problem but it did) so, after installing I was getting massive frame rate drops and was failing benchmark tests on the GPU. A clean install did not help so I ran benchmark test again, same problem so I looked at the logs and it was reporting "sphere GPU benchmark failed" Anyway, I had checked all the obvious things like thermal paste, connections etc and all good.

So then onto internet searches and it was very common and most were pointing to driver issues and specifically Realtek audio drivers.

I eventually came across a posting where a guy commented that he had experienced exactly the same issue after fitting new components and it was due to his Realtek Audio Driver working in sync with Nahimic 3 which some MB manufacturers use and advised to only use stock audio drivers and to not download the Realtek/Nahimic drivers from the MB manufacturer. It seems to be interfering with DirectX as you can see in the image.

Here was the fix he advised and it worked perfectly for me.

Re install OS from from USB, once online run benchmark and if all okay then go into services and completely disable Nahimic (not delete). Then make sure not to download Realtek Audio if not already installed.

Then search for your windows.old folders, do not right click to delete the folders but right click properties tab, perform disk clean up and check mark the tab that asks if you want to delete previous versions of Windows and carry out thus deleting the overwritten version which as you will know also frees up disc space.

Run benchmark again to see if all okay and if it is then you are good to go but will be using normal audio drivers.

He said the problem is arising with Realtek Drivers working alongside Nahimic 3 which in my case with an MSI MB they do.

Anyway, I seem to have it all sorted now and working well under load with a good FPS again and no problems.

So the lesson for me here is avoid Nahimic 3 for now and also the Realtek Audio Driver if it does not come pre-installed but has to be downloaded from MB manufacturer.

Hope this helps someone.

Scotty.
 

ASK THE COMMUNITY

TRENDING THREADS