[SOLVED] Drops to ~3 FPS in all games every 2-20 minutes, CPU Utilization drops to 4%

Status
Not open for further replies.
Apr 17, 2020
2
0
20
0
Hello everyone,

G5 15 5590 laptop here. For about 1 1/2 months I've had this problem (can't tell exactly when since I haven't been gaming lately) where, in every single game I play and every 2-5 minutes, my FPS will be drastically lower (3) for a minute, then come back up. The reason I posted to the Windows 10 forum will become evident in the following.

During this my temps are fine (seen it happen at 70-80°C CPU and 70°C GPU) and the clocks stay at max turbo. When looking at the task manager, I can see the game's CPU utilization drop from a normal value (24-75%) to <=8% (coincidentally that is 1 thread). Meanwhile the GPU Utilization doesn't seem to change. Interestingly, the system remains perfectly responsive, no audio crackling et cetera occurs. As I only ever play on AC, I cant speak for battery mode in terms of whether it occurs there.

Examples:
  • Minecraft Server (3 Clients) & Client running on Laptop: FPS drop from 200-2000 to 50, participants notice no server lag or audio buffer crackling in voice chat. It occurs for the first time after ~10 minutes.
  • Rocket League: FPS drop from 250 to 5, Happens after 20 minutes.
  • Assassin's Creed Unity/Syndicate: FPS drop from 60+ to 3, if someone is connected via Parsec and Discord, they can see it too. Here it seems to happen in two steps, with the intermediate one being 10 fps for 10 seconds on both start and end of the drop. Video and audio encoding for Parsec et cetera don't seem to be impacted. The problem first occurs after ~5 minutes, then it repeats every 2.
It happens in every game from Portal to Need For Speed with different levels of intensity, all of which being very noticeable.

Generally the frequency of events seems to be higher after the first occurrence which would point towards thermals, but I have already ruled those out as the root cause.

What I've tried so far:
  • Windows reinstall
  • Safe mode DDU and graphics driver reinstall
  • Reinstalled all drivers, installed all seemingly useless ones from Dell and the accompanying software on top
  • Changed power plans (drops occur on both balanced and high performance, maybe a little more often on the latter, not sure)
  • Removed dust
  • Reflash and reset BIOS settings
  • Xperf (no new intelligence, might just be too inexperienced with it to retrieve it though)
  • Synthetic Load Testing (e.g. Prime 95, Furmark and both at the same time): Doesn't happen during it.
  • Undervolting, Overclocking
Haven't done a Windows rollback because those are a pain in the a**.

Short summary:
  • FPS momentarily (1 minute every few minutes) drop to an unplayable fraction of the norm
  • CPU utilization drops, GPU doesn't
  • temps and clocks are fine
System information:
  • DELL G5 5590
  • Windows 10 Pro 2004 19041
  • Intel Core i7-9750H (100.0Mhz steps, 8x minimum, 26x base; 45x, 44x, 43x, 42x, 41x, 40x max turbo) with Intel UHD Graphics 630
  • NVIDIA GeForce RTX 2060 6GB (Driver 445.87)
  • 2x8GB Kingston KHYXPX-MIE DDR4-2666 SDRAM
  • Samsung SSD 970 EVO 1TB & Samsung SSD 860 EVO 500GB
  • Killer E2500 Gigabit Ethernet Controller
I have found a very recent post that seems to describes a similar issue (can't tell because not detailed enough) with a different laptop brand but doesn't have any replies to it yet:

My above description is making me think that this is some kind of scheduling issue with windows or a (graphics) driver problem. As mentioned, I couldn't trace back the exact date it started because I hadn't hit it with the workload concerned (gaming) in a while.

If none of you can think of a potential easy solution I'll have bust out the big guns and get to work on the more tedious and time consuming fixes I can think of which I've been avoiding for the longest time because I have been needing it to work for normal use recently.

Thank you all for your time and ideas

c76
 
Last edited:
Apr 17, 2020
2
0
20
0
It was a BIOS bug that would hard throttle both the CPU and GPU at totally reasonable temperatures. Reverting to the earliest one compatible with my CPU and then upgrading to the newest one solved it.
 
Status
Not open for further replies.

ASK THE COMMUNITY