Dual Monitor- Cannot recognise second Monitor

Status
Not open for further replies.

GandivaNaismith

Honorable
May 5, 2012
16
0
10,510
I have a 2GB Radeon 6900 series graphic card and setting up second 1280 x 1024 monitor.
I thought the thing would just be recognised when I booted the pc.

No, it cannot be recongised.
Windows help brilliant suggestion was to run RegCure Pro $30 later I did.

Might have cleaned my registry but still can't recognise monitor.

Updated latest download from ARI Radeon but Catalyst still can't find the monitor.

And I also tried turning it off and turning it on again.

I am running out of Voodoo tricks. Can I have help ?
 

Idonno

Distinguished
Jan 3, 2011
694
0
19,060

CF=CrossFire, DP=Display port

I still need answers to my last questions.
 

rdc85

Honorable


looks like a bad DVI port, do u check the adaptor? if the adapter is fine, can u rma the card?

I once tested by simply random plung in to random dvi port after reboot twice it will automaticaly set the port plunged in as primary display port.. so in your case seems like bad adaptor, or bad port (card)
 

GandivaNaismith

Honorable
May 5, 2012
16
0
10,510
I read Wikipedia for DVI and read the specs of my graphics card. It appears that I have one Single link DVI and one Dual Link DVI . Useless, can't work.

Why couldn't they both be dual link so that I could convert to analog monitors.
 

rdc85

Honorable
Both of your DVI port in your card seems to have the analog hole (DVI-I) you now like this: (C1 - C5 in wiki picture)

o o
---- or
o o

o|o
----
o|o

so it should not be matter if it single or dual link because this four hole the VGA adapter will be using....
looks like a failed port if i must say......

RMA is return it to the place u buy it to get replacement or send it to the manufacture (XFX) to get repaired..... as long as it still in waranty

edit actualy it not only four hole it used but that is what most importance for DVI to VGA adaptor........
 

rdc85

Honorable
Well, not that i know, ATI/AMD catalyst is very good / simple at multi monitor set up.....

I have 2 card in cfx total 4 dvi port, once i tried randomly plung in and plung out each dvi port (just for curiosity sake, i'm also using vga adaptor back then)

It just takes 2 reboot maximum to let it automaticaly set display to my monitor (sometimes it doesn't need reboot when u are not in cfx mode). so i doubt the problem in software side....

could u try older catalyst (driver) to rule out the driver issue (u can always tried the one that came with the vga card / driver cd, usually they had older working driver in it)...............
 

Idonno

Distinguished
Jan 3, 2011
694
0
19,060
Have you gone into the catalyst control center and set up a desktop? (under creating and arranging desktops)

If not go there and see if catalyst control center recognizes that you have 2 connected, If so set up a desktop.
 

Idonno

Distinguished
Jan 3, 2011
694
0
19,060
Your power supply should be plenty strong for what you have as long as it's still working properly.

Quite frankly I'm as stumped as you are. It's starting to look like an RMA is in order if the manufactures tech support can't help.
 

louynics

Honorable
Aug 14, 2012
1
0
10,510
Hi i am having the same problem and i thought it was the power supply for a while, so i tested it with a 750w and it made no difference
Have you found a sultion yet?
 
Status
Not open for further replies.