Question Dual monitor issue, programs from toolbar gone after monitor turns on.

Feb 21, 2022
7
0
10
0
Greetings friends

Currently I'm having a issue which is driving me a bit mad.

This is my issue:

So recently I got myself 2x new monitors, 1x 49" (connected with DisplayPort, primary monitor) and 1x 32" (connected with HDMI, secondary monitor), they are both connected to the desktop computer. And every time I turn OFF and ON the 49" monitor, all programs and icons in the windows toolbar is gone, and if I try to start a new program (whatever program) nothing happens, its just loading forever. (Cant do nothing) .I have try to restart the Windowsexplorer.exe from Task manager with no luck.

Currently my only solution for this is to Log off the user and Log back in again, and then everything is working fine.

But if I turn the 32" monitor ON and OFF, nothing happens, everything works flawless.

So anyone have any idea why this happens, and the cause of it?



Appreciate all help I get :)
 

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS information.

Make and model monitors? 49" Monitor being primary - correct?

What is causing the need to turn the 49" Monitor ON and OFF? Or you just do that when finished using the computer?

Just for the record: Do you normally keep the taskbar along the bottom of the 49" monitor?

What PROJECT Mode are you using via "WIN" + "P"? PC screen only, Duplicate, Extend, or Second screen only?

At the next successful boot and the task bar is visible, right click an empty spot in the taskbar.

Then click Taskbar settings icon. Check the settings there.

Likewise, click an empty area of the desktop and access the control panel for your GPU.

Check that all of the settings are correct and as required.
 

Inthrutheoutdoor

Reputable
BANNED
Feb 17, 2019
255
66
4,790
6
  1. How recent is your desktop machine
  2. Do you have a discrete video card with multiple outputs, or are you using the integrated video on the mobo ? Some of the older ones are just not powerful enough to drive 2 monitors....
  3. Do you have the most recent drivers & bios for both your mobo & gpu ?
  4. As mentioned above, also check your display settings. Open the settings app, go to system > Display, then scroll down where it says "Multiple displays" and choose "extend these displays" and restart.
This should put & keep the taskbar & all icons at the bottom of both monitors, however, if you really find it necessary to power down your monitors after each use, I have found that the above settings seem to work better if you turn the monitors on before booting up the pc...

I have 3 monitors connected to my mini-me box pc with fairly recent integrated graphics and have not had any problems like this..
 
Feb 21, 2022
7
0
10
0
Thank you Raiston18 for reaching out already.

Some more information:
  • Downloaded the newest driver and installed it.
  • The 49" is my primary monitor.
  • Reason for turning OFF the monitor is when I am finished using the computer (didn't have this problem in my previous dual monitor setup)
  • Regarding the taskbar, yes i always have the taskbar at the bottom.
  • The project mode is Extend.
  • Check Taskbar settings and GPU and everything looked good.
The 49" is using 5120x1440 resolution, 100% Scaling with 60Hz (connected with DisplayPort, primary monitor)
While the 32" is using 3840x2160 resolution, 100% Scaling with 60Hz (connected with HDMI, secondary monitor)

GPU:
Brand new: MSI GeForce RTX 3060 GAMING X
Driver version: 516.94

Spent some time today also to fix this issue, but still a tiresome issue.
Never had this issue before, but i think the DisplayPort for the 49" is one of the big factor for the issue, because this does not happen when the 32" monitor is turnt ON and OFF,.

Hope this gave you more information.

Edit:
To Inthrutheoutdoor
  1. Only few months old, brand new 3060 GPU, 5950x CPU.
  2. I'm using the 3060 GPU for the output (1x DisplayPort and 1x HDMI)
  3. Most recent drivers: yes. Bios: not so sure.
  4. Done that already, still same issue.
I'm guessing your mini-me box is connect with only HDMI/DVI. Then we are coming back to the DisplayPort part again, seems like this is the underling issue. My previous dual monitor setup used HDMI and DVI only, and it worked for 6-7 perfectly!

Had an idea to use an DisplayPort/HDMI adapter but the monitor wont support 5K HDMI cable..

Anyone has any solution for this nightmare?

Thanks friends!
 

Inthrutheoutdoor

Reputable
BANNED
Feb 17, 2019
255
66
4,790
6
To Inthrutheoutdoor

I'm guessing your mini-me box is connect with only HDMI/DVI.

Thanks friends!
Actually my box has 2x native HDMI outputs, and I have an HDMI 2-port hub connected to the USB-C/TB4 port, so I could technically use 4 displays if needed, but I am only using 3 ATM...

I ditched anything & everything DVI-related (same with the USB-A/B/mini/micro crapfest) several years ago :)
 

ASK THE COMMUNITY

TRENDING THREADS