DualShock4 suddenly not recognized by my PC

Mar 7, 2019
1
0
10
0
I was playing DMC5 perfectly fine for 2 hours straight using my DS4 (Big Picture Steam, PS4 controller configuration).

Never had a single problem with the controller in my life. Suddenly, the light just goes off. It goes from blue, to orange, to blank.

The error is "Device descriptor request failed" and a code 43. Now, I tried literally everything I could find on google, I've been troubleshooting for 3 hours now. Tried every port on my PC (when I change the port the controller works for either 10 seconds, or until I move it even slightly). I changed the cable, nothing. I installed different drivers (xbox, 360, ds4w), nothing. I did everything in the device manager (uninstall,disable,restart the pc), nothing. I checked for windows updates, installed them, nothing. Bios updates, nothing. The controller, with the same cable, works perfectly fine on my laptop. It recognizes it instantly. Also, on my desktop, all the other USB devices work just fine. I tried the reset button behind the controller, nothing. I tried other wired controllers on my desktop, they work perfectly fine. I literally have 0 ideas or reasoning for why might this be happening, because it makes ZERO sense. What the hell do I do? I am so angry cuz I waited 11 god damn years for DMC5 only to be fucked over by DS4 that suddenly, (with no changes to the system), decided to stop working.
 

ASK THE COMMUNITY